Project

General

Profile

SupportedPlatforms

Currently, we support ifdhc on Scientific Linux, and compatable platforms (i.e. RedHat, CentOS). It should build and run on other platforms (for suitable values of "run"), but to operate properly, we need various underlying packages available, not the least of which is various parts of the osg-client bundle from the Open Science Grid, and they (OSG) in turn support only RedHat/ScientificLinux/CentOS systems.

If folks want to get the parts needed (lcg-cp, uberftp, gfal-cp, gfal-ls, xrdcp, xrdfs, irods, openssl, etc.)
built for some other platform, then they can build & test ifdhc there and it will probalby work. But we don't have effort available
to do that, and with out supported versions of the relied-upon tools, we cannot support ifdhc itself.

If you don't want to install the entire osg-client bundle, it appears minimal functionality can
be achieved with:

globus-gss-assist-8.1-4.1.osg31.el6.x86_64
globus-xio-gsi-driver-2.1-4.1.osg31.el6.x86_64
osg-ca-certs-1.43-1.osg31.el6.noarch
voms-clients-2.0.11-2.3.osg31.el6.x86_64
globus-gsi-proxy-core-6.1-4.1.osg31.el6.x86_64
globus-ftp-control-4.2-7.osg31.el6.x86_64
voms-2.0.11-2.3.osg31.el6.x86_64
uberftp-2.8-1.osg31.el6.x86_64
vo-client.58-3.osg31.el6.noarch

OSX notes

Some pieces which should be sufficient for basic use of ifdhc on OSX have been identified and bundled as ifdh_platform_pkgs, available via upd, or through scisoft. Official support should be requested from OSG.

Tools found via: