Project

General

Profile

FNAL Lab 3 Test Stand

Network

PCs

  • gm2straw6
  • gm2straw7

A common user "gm2" should be used when running the DAQ. To login you will be asked for these 3 pieces of info:

  • User name: gm2
  • Password: Your own kerberos password
  • Principal: Your own kerberos principal

Fermilab network

Device IP address
gm2straw6 131.225.38.16
gm2straw7 131.225.38.19

For gm2straw6, the lower ethernet port is the Fermilab network and the upper is the local network. It is the other way around for gm2straw7.

Local network

Subnet is 192.168.1.x.

Device IP address MAC address
gm2straw6 192.168.1.1
gm2straw7 192.168.1.2
MCH eth0 192.168.1.8
MCH eth1 192.168.1.9
AMC13 T1 192.168.1.111
AMC13 T2 192.168.1.110
FC7 slot 3 192.168.1.3 fc:07:00:00:00
FC7 slot 4 192.168.1.4 fc:07:00:00:01
GLIB (LB emulator FW) 192.168.1.10
GLIB (DAQ FW) 192.168.1.11

Software

Online

You must be the gm2 user for this to work.

The online (DAQ/DQM) code can be found here (or use the online alias):

/home/nfs/gm2/lab3TestStand/online

See the DAQ user manual here: https://cdcvs.fnal.gov/redmine/projects/gm2trackerdaq/wiki/ProductionRunningTheCode

See the DQM user manual here: https://cdcvs.fnal.gov/redmine/projects/gm2trackerdaq/wiki/ProductionDQM

See the DQM user manual here: https://cdcvs.fnal.gov/redmine/projects/gm2trackerdaq/wiki/Databases_

Use the aliases daq and dqm to cd to the relevant directories.

Offline

You must be the gm2 user for this to work.

The offline (art) code can be found here (or use the offline alias):

/home/nfs/gm2/lab3TestStand/offline

To configure the environment, use:

offline
. setup.sh

Firmware

Firmware is being stored here:

/home/nfs/gm2/lab3TestStand/online/firmware

Updating the Logic Board firmware

python test/programFlash.py -f ../../firmware/lb/LogicBoard-10-06-06-01.mcs -lb AMC13-0/FC7-0/LB-0

Updating GLIB firmware

If need to use GLIB for anything (normally you don't), need to load firmware on the GLIB via a Xilinx USB-JTAG cable. Do this using impact as follows:

1) Become root

ksu

2) Setup environment:

source $XILINX_SETTINGS 

Note that this assumes you are already set up the DAQ environment (e.g. sourced trackerDaq-setup.sh).

3) Load firmware via impact in the usual way

Must start impact as root.

Offline data processing

For overall tier 0 software guide, see here .

A script for processing runs called gm2tracker/fcl/ProcessRuns.py is available. Tell this what fcl files to run and what run numbers to run on. Run as:

python $MRB_SOURCE/gm2tracker/fcl/ProcessRuns.py -c <list of fcl fils to run (in order)> -r <list of run numbers> (-n <num events>) 

This assumes the following environment variables are set:

  • MIDAS_ONLINE_DATA - Directory MIDAS files are written to
  • OFFLINE_DATA_DIR - Directory to write offline data files to

Alternatively can specify input, output and MIDAS data directories using the -i, -o and -m args respectively.

A few useful examples:

Unpack run 1:

python $MRB_SOURCE/gm2tracker/fcl/ProcessRuns.py -c $MRB_SOURCE/gm2unpackers/fcl/Lab3Unpacker.fcl -r 1

Run all stages in unpacking, readout and reco chain for runs 10 and 15, and also all plotters:

python $MRB_SOURCE/gm2tracker/fcl/ProcessRuns.py -c $MRB_SOURCE/gm2unpackers/fcl/Lab3Unpacker.fcl $MRB_SOURCE/gm2unpackers/fcl/Lab3UnpackerPlots.fcl $MRB_SOURCE/gm2tracker/fcl/Lab3Readout.fcl $MRB_SOURCE/gm2tracker/fcl/Lab3ReadoutPlots.fcl $MRB_SOURCE/gm2tracker/fcl/Lab3Reco.fcl $MRB_SOURCE/gm2tracker/fcl/Lab3RecoPlots.fcl -r 10 15

Troubleshooting

Cannot ping anything on local network from gm2straw6

gm2straw6 sometimes reverts its network settings back to old settings. Maybe we need to disable the NetworkManager or something like that? In the meantime, fix it as root by setting the IP address in /etc/sysconfig/network-scripts/ifcfg-eth1 as 192.168.1.1, and restarting the machine.

To try and stop this, I removed write permissions from /etc/sysconfig/network-scripts/ifcfg-eth1 (as root). If you need to edit this file again, put the write permissions back using (as root):

chmod u+w /etc/sysconfig/network-scripts/ifcfg-eth1

gm2straw6 won't start up

Sometimes gm2straw6 fails to start when switched on, and just fills the screen is full of messages like "SysRq help reboot crash terminate-all-ask". Unplugging the cable from the CAEN HV units into the PC solved this.

It didn't used to do this, so I'm not sure if we have an underlying problem. You can plug in the cable after start up seemingly without trouble, but I haven't tried the HV GUI yet.