Project

General

Profile

Initial config of test nodes at LCCNML

Current, 2012.09.13 status:
Nodes are reachable via rsh from cluck.fnal.gov. Root password is pa***ord.
Hostnames, accounts, nfs, IB network, etc have not been set up.

More details (what was done):
KOI did a basic install of SLF6.3.
This install did not set any of the IP addresses so the nodes are unreachable from the network.
Previously, I had visited all the nodes and configured the IPMI interface with static addresses.
I was assigned addresses by Amitoj and put the information into the /etc/hosts file on cluck.fnal.gov.
Cluck.fnal.gov was configure (interface alias) to allow connectivity to the IPMI interfaces.
The default user/password for ipmi web interface is ADMIN/A**IN

I was able to connect to each nodes console via IPMI with the following details:

For the 5 "FR" nodes, the console web-start launch.jnlp needed to be saved and patched and then
manually invoked via /usr/bin/javaws program.
Patch:

*** dsfr2.jnlp.~1~      Wed Sep 12 12:19:14 2012
--- dsfr2.jnlp  Wed Sep 12 12:19:47 2012
***************
*** 34,42 ****
--- 34,46 ----
    </resources>
    <resources os="Linux" arch="x86_64">
      <nativelib href="liblinux_x86_64.jar" download="eager" version="1.0.3"/>
+     <property name="jnlp.packEnabled" value="true"/>
+     <property name="jnlp.versionEnabled" value="true"/>
    </resources>
    <resources os="Linux" arch="amd64">
      <nativelib href="liblinux_x86_64.jar" download="eager" version="1.0.3"/>
+     <property name="jnlp.packEnabled" value="true"/>
+     <property name="jnlp.versionEnabled" value="true"/>
    </resources>

    <resources os="Mac OS X" arch="x86_64">

For the 7 "EB" nodes, the console connection worked except all mouse clicks were associated
to the top-left part of the screen. So the configuration needed to be down basically with only
one mouse click which luckily caused the opening of a KDE top screen menu bar drop down menu.

The configuration down on each node:
  1. configure /etc/sysconfig/network-scripts/ifcfg-eth0 as such:
    BOOTPROTO=static
    NM_CONTROLLED=no
    ONBOOT=yes
    IPADDR=192.168.76.
    NETMASK=255.255.255.0
    Then ifup eth0
  2. configure /etc/yum.conf
    add line "proxy=http://192.168.76.79:3128/" at end.
  3. yum install rsh-server
  4. for ss in rexec rlogin rsh;do chkconfig $ss on;done
    service xinetd restart
  5. service iptables stop; chkconfig iptables off
  6. edit /etc/hosts.allow
    add "192.168." to ALL
  7. edit /etc/securetty
    add lines at top:
    rexec
    rlogin
    rsh