Project

General

Profile

Enabling Ganglia monitoring on the WH14NE teststand

02-Dec-2014, KAB: these are notes on the steps that I used.

Installed httpd

[root@dsfr6 ~]# yum list httpd
Loaded plugins: auto-update-debuginfo, fastestmirror, protectbase, security
Determining fastest mirrors
slf                                                                                                                            | 3.5 kB     00:00     
slf-debuginfo                                                                                                                  | 2.6 kB     00:00     
slf-debuginfo/primary_db                                                                                                       | 2.8 MB     00:00     
slf-security                                                                                                                   | 3.0 kB     00:00     
0 packages excluded due to repository protections
Available Packages
httpd.x86_64                                                        2.2.15-31.sl6                                                         slf-security
[root@dsfr6 ~]# yum install httpd
Loaded plugins: auto-update-debuginfo, fastestmirror, protectbase, security
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package httpd.x86_64 0:2.2.15-31.sl6 will be installed
--> Processing Dependency: httpd-tools = 2.2.15-31.sl6 for package: httpd-2.2.15-31.sl6.x86_64
--> Processing Dependency: apr-util-ldap for package: httpd-2.2.15-31.sl6.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.2.15-31.sl6.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.2.15-31.sl6.x86_64
--> Running transaction check
---> Package apr.x86_64 0:1.3.9-5.el6_2 will be installed
---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be installed
---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be installed
---> Package httpd-tools.x86_64 0:2.2.15-31.sl6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                              Arch                          Version                                 Repository                           Size
======================================================================================================================================================
Installing:
 httpd                                x86_64                        2.2.15-31.sl6                           slf-security                        823 k
Installing for dependencies:
 apr                                  x86_64                        1.3.9-5.el6_2                           slf                                 122 k
 apr-util                             x86_64                        1.3.9-3.el6_0.1                         slf                                  86 k
 apr-util-ldap                        x86_64                        1.3.9-3.el6_0.1                         slf                                  15 k
 httpd-tools                          x86_64                        2.2.15-31.sl6                           slf-security                         73 k

Transaction Summary
======================================================================================================================================================
Install       5 Package(s)

Total download size: 1.1 M
Installed size: 3.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): apr-1.3.9-5.el6_2.x86_64.rpm                                                                                            | 122 kB     00:00     
(2/5): apr-util-1.3.9-3.el6_0.1.x86_64.rpm                                                                                     |  86 kB     00:00     
(3/5): apr-util-ldap-1.3.9-3.el6_0.1.x86_64.rpm                                                                                |  15 kB     00:00     
(4/5): httpd-2.2.15-31.sl6.x86_64.rpm                                                                                          | 823 kB     00:00     
(5/5): httpd-tools-2.2.15-31.sl6.x86_64.rpm                                                                                    |  73 kB     00:00     
------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                 3.7 MB/s | 1.1 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : apr-1.3.9-5.el6_2.x86_64                                                                                                           1/5 
  Installing : apr-util-1.3.9-3.el6_0.1.x86_64                                                                                                    2/5 
  Installing : httpd-tools-2.2.15-31.sl6.x86_64                                                                                                   3/5 
  Installing : apr-util-ldap-1.3.9-3.el6_0.1.x86_64                                                                                               4/5 
  Installing : httpd-2.2.15-31.sl6.x86_64                                                                                                         5/5 
  Verifying  : httpd-tools-2.2.15-31.sl6.x86_64                                                                                                   1/5 
  Verifying  : apr-1.3.9-5.el6_2.x86_64                                                                                                           2/5 
  Verifying  : httpd-2.2.15-31.sl6.x86_64                                                                                                         3/5 
  Verifying  : apr-util-1.3.9-3.el6_0.1.x86_64                                                                                                    4/5 
  Verifying  : apr-util-ldap-1.3.9-3.el6_0.1.x86_64                                                                                               5/5 

Installed:
  httpd.x86_64 0:2.2.15-31.sl6                                                                                                                        

Dependency Installed:
  apr.x86_64 0:1.3.9-5.el6_2    apr-util.x86_64 0:1.3.9-3.el6_0.1    apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1    httpd-tools.x86_64 0:2.2.15-31.sl6   

Complete!

Installed Firefox

[root@dsfr6 ~]# yum list firefox
Loaded plugins: auto-update-debuginfo, fastestmirror, protectbase, security
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Available Packages
firefox.i686                                                         31.2.0-3.el6_6                                                       slf-security
firefox.x86_64                                                       31.2.0-3.el6_6                                                       slf-security
[root@dsfr6 ~]# yum install firefox
Loaded plugins: auto-update-debuginfo, fastestmirror, protectbase, security
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package firefox.x86_64 0:31.2.0-3.el6_6 will be installed
--> Processing Dependency: nss >= 3.16.1 for package: firefox-31.2.0-3.el6_6.x86_64
--> Processing Dependency: nspr >= 4.10.6 for package: firefox-31.2.0-3.el6_6.x86_64
--> Processing Dependency: libvpx >= 1.3.0 for package: firefox-31.2.0-3.el6_6.x86_64
--> Processing Dependency: system-bookmarks for package: firefox-31.2.0-3.el6_6.x86_64
--> Processing Dependency: libvpx.so.1()(64bit) for package: firefox-31.2.0-3.el6_6.x86_64
--> Running transaction check
---> Package libvpx.x86_64 0:1.3.0-5.el6_5 will be installed
---> Package nspr.x86_64 0:4.9.5-2.el6_4 will be updated
---> Package nspr.x86_64 0:4.10.6-1.el6_5 will be an update
---> Package nss.x86_64 0:3.14.3-4.el6_4 will be updated
--> Processing Dependency: nss = 3.14.3-4.el6_4 for package: nss-sysinit-3.14.3-4.el6_4.x86_64
--> Processing Dependency: nss = 3.14.3-4.el6_4 for package: nss-tools-3.14.3-4.el6_4.x86_64
---> Package nss.x86_64 0:3.16.1-7.el6_5 will be an update
--> Processing Dependency: nss-util >= 3.16.1 for package: nss-3.16.1-7.el6_5.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.17.1)(64bit) for package: nss-3.16.1-7.el6_5.x86_64
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.15)(64bit) for package: nss-3.16.1-7.el6_5.x86_64
---> Package slf-bookmarks.noarch 0:6-1.slf6 will be installed
--> Running transaction check
---> Package nss-sysinit.x86_64 0:3.14.3-4.el6_4 will be updated
---> Package nss-sysinit.x86_64 0:3.16.1-7.el6_5 will be an update
---> Package nss-tools.x86_64 0:3.14.3-4.el6_4 will be updated
---> Package nss-tools.x86_64 0:3.16.1-7.el6_5 will be an update
---> Package nss-util.x86_64 0:3.14.3-3.el6_4 will be updated
---> Package nss-util.x86_64 0:3.16.1-2.el6_5 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                              Arch                          Version                                 Repository                           Size
======================================================================================================================================================
Installing:
 firefox                              x86_64                        31.2.0-3.el6_6                          slf-security                         60 M
Installing for dependencies:
 libvpx                               x86_64                        1.3.0-5.el6_5                           slf-security                        485 k
 slf-bookmarks                        noarch                        6-1.slf6                                slf                                 8.0 k
Updating for dependencies:
 nspr                                 x86_64                        4.10.6-1.el6_5                          slf-security                        112 k
 nss                                  x86_64                        3.16.1-7.el6_5                          slf-security                        832 k
 nss-sysinit                          x86_64                        3.16.1-7.el6_5                          slf-security                         40 k
 nss-tools                            x86_64                        3.16.1-7.el6_5                          slf-security                        360 k
 nss-util                             x86_64                        3.16.1-2.el6_5                          slf-security                         64 k

Transaction Summary
======================================================================================================================================================
Install       3 Package(s)
Upgrade       5 Package(s)

Total download size: 62 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): firefox-31.2.0-3.el6_6.x86_64.rpm                                                                                       |  60 MB     00:05     
(2/8): libvpx-1.3.0-5.el6_5.x86_64.rpm                                                                                         | 485 kB     00:00     
(3/8): nspr-4.10.6-1.el6_5.x86_64.rpm                                                                                          | 112 kB     00:00     
(4/8): nss-3.16.1-7.el6_5.x86_64.rpm                                                                                           | 832 kB     00:00     
(5/8): nss-sysinit-3.16.1-7.el6_5.x86_64.rpm                                                                                   |  40 kB     00:00     
(6/8): nss-tools-3.16.1-7.el6_5.x86_64.rpm                                                                                     | 360 kB     00:00     
(7/8): nss-util-3.16.1-2.el6_5.x86_64.rpm                                                                                      |  64 kB     00:00     
(8/8): slf-bookmarks-6-1.slf6.noarch.rpm                                                                                       | 8.0 kB     00:00     
------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                 9.8 MB/s |  62 MB     00:06     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : nspr-4.10.6-1.el6_5.x86_64                                                                                                        1/13 
  Updating   : nss-util-3.16.1-2.el6_5.x86_64                                                                                                    2/13 
  Updating   : nss-3.16.1-7.el6_5.x86_64                                                                                                         3/13 
  Updating   : nss-sysinit-3.16.1-7.el6_5.x86_64                                                                                                 4/13 
  Installing : libvpx-1.3.0-5.el6_5.x86_64                                                                                                       5/13 
  Installing : slf-bookmarks-6-1.slf6.noarch                                                                                                     6/13 
  Installing : firefox-31.2.0-3.el6_6.x86_64                                                                                                     7/13 
  Updating   : nss-tools-3.16.1-7.el6_5.x86_64                                                                                                   8/13 
  Cleanup    : nss-tools-3.14.3-4.el6_4.x86_64                                                                                                   9/13 
  Cleanup    : nss-sysinit-3.14.3-4.el6_4.x86_64                                                                                                10/13 
  Cleanup    : nss-3.14.3-4.el6_4.x86_64                                                                                                        11/13 
  Cleanup    : nss-util-3.14.3-3.el6_4.x86_64                                                                                                   12/13 
  Cleanup    : nspr-4.9.5-2.el6_4.x86_64                                                                                                        13/13 
  Verifying  : nspr-4.10.6-1.el6_5.x86_64                                                                                                        1/13 
  Verifying  : firefox-31.2.0-3.el6_6.x86_64                                                                                                     2/13 
  Verifying  : slf-bookmarks-6-1.slf6.noarch                                                                                                     3/13 
  Verifying  : libvpx-1.3.0-5.el6_5.x86_64                                                                                                       4/13 
  Verifying  : nss-3.16.1-7.el6_5.x86_64                                                                                                         5/13 
  Verifying  : nss-sysinit-3.16.1-7.el6_5.x86_64                                                                                                 6/13 
  Verifying  : nss-util-3.16.1-2.el6_5.x86_64                                                                                                    7/13 
  Verifying  : nss-tools-3.16.1-7.el6_5.x86_64                                                                                                   8/13 
  Verifying  : nspr-4.9.5-2.el6_4.x86_64                                                                                                         9/13 
  Verifying  : nss-sysinit-3.14.3-4.el6_4.x86_64                                                                                                10/13 
  Verifying  : nss-tools-3.14.3-4.el6_4.x86_64                                                                                                  11/13 
  Verifying  : nss-3.14.3-4.el6_4.x86_64                                                                                                        12/13 
  Verifying  : nss-util-3.14.3-3.el6_4.x86_64                                                                                                   13/13 

Installed:
  firefox.x86_64 0:31.2.0-3.el6_6                                                                                                                     

Dependency Installed:
  libvpx.x86_64 0:1.3.0-5.el6_5                                            slf-bookmarks.noarch 0:6-1.slf6                                           

Dependency Updated:
  nspr.x86_64 0:4.10.6-1.el6_5         nss.x86_64 0:3.16.1-7.el6_5     nss-sysinit.x86_64 0:3.16.1-7.el6_5     nss-tools.x86_64 0:3.16.1-7.el6_5    
  nss-util.x86_64 0:3.16.1-2.el6_5    

Complete!

Updated gtk2* to get Firefox to work

[root@dsfr6 ~]# yum list gtk2*
Loaded plugins: auto-update-debuginfo, fastestmirror, protectbase, security
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Installed Packages
gtk2.x86_64                                             2.18.9-10.el6                           @anaconda-SLFSecurityUpdates-201208160843.x86_64
gtk2-engines.x86_64                                     2.18.4-5.el6                            @slf                                            
Available Packages
gtk2.i686                                               2.24.23-6.el6                           slf-security                                    
gtk2.x86_64                                             2.24.23-6.el6                           slf-security                                    
gtk2-debuginfo.i686                                     2.24.23-6.el6                           slf-debuginfo                                   
gtk2-debuginfo.x86_64                                   2.24.23-6.el6                           slf-debuginfo                                   
gtk2-devel.i686                                         2.24.23-6.el6                           slf-security                                    
gtk2-devel.x86_64                                       2.24.23-6.el6                           slf-security                                    
gtk2-devel-docs.x86_64                                  2.24.23-6.el6                           slf-security                                    
gtk2-engines.i686                                       2.18.4-5.el6                            slf                                             
gtk2-engines-debuginfo.i686                             2.18.4-5.el6                            slf-debuginfo                                   
gtk2-engines-debuginfo.x86_64                           2.18.4-5.el6                            slf-debuginfo                                   
gtk2-engines-devel.i686                                 2.18.4-5.el6                            slf                                             
gtk2-engines-devel.x86_64                               2.18.4-5.el6                            slf                                             
gtk2-immodule-xim.i686                                  2.24.23-6.el6                           slf-security                                    
gtk2-immodule-xim.x86_64                                2.24.23-6.el6                           slf-security                                    
gtk2-immodules.i686                                     2.24.23-6.el6                           slf-security                                    
gtk2-immodules.x86_64                                   2.24.23-6.el6                           slf-security                                    
[root@dsfr6 ~]# yum update gtk2*
Loaded plugins: auto-update-debuginfo, fastestmirror, protectbase, security
Loading mirror speeds from cached hostfile
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gtk2.x86_64 0:2.18.9-10.el6 will be updated
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libnotify-0.5.0-1.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libgnomecanvas-2.26.0-4.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libcanberra-gtk2-0.22-1.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: xpra-0.10.4-2.el6_3.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: latencytop-0.5-9.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: pygtk2-libglade-2.16.0-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: gtkglext-libs-1.2.0-11.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: xulrunner-17.0.8-3.el6_4.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: gtk2-2.24.23-6.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: gtk2-engines-2.18.4-5.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libglade2-2.6.4-3.1.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libfprint-0.1.0-19.pre2.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libwnck-2.28.0-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: icedtea-web-1.2.3-4.el6_4.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: python-matplotlib-0.99.1.2-1.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: usermode-gtk-1.102-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: zenity-2.28.0-1.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: notification-daemon-0.5.0-1.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: gnome-python2-canvas-2.28.0-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: gnome-keyring-2.28.2-7.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: firefox-31.2.0-3.el6_6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: librsvg2-2.26.0-5.el6_1.1.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: unison227-2.27.57-13.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: notify-python-0.1.1-10.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: metacity-2.28.0-23.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: 1:emacs-23.1-21.el6_2.3.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: libreport-gtk-2.0.9-5.el6_3.2.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: pygtk2-2.16.0-3.el6.x86_64
--> Processing Dependency: libgdk_pixbuf-2.0.so.0()(64bit) for package: pygtkglext-1.1.0-7.1.el6.x86_64
--> Processing Dependency: libgdk_pixbuf_xlib-2.0.so.0()(64bit) for package: redhat-lsb-graphics-4.0-3.el6.x86_64
---> Package gtk2.x86_64 0:2.24.23-6.el6 will be an update
--> Processing Dependency: glib2 >= 2.28.0-1 for package: gtk2-2.24.23-6.el6.x86_64
--> Processing Dependency: atk >= 1.29.4-2 for package: gtk2-2.24.23-6.el6.x86_64
--> Running transaction check
---> Package atk.x86_64 0:1.28.0-2.el6 will be updated
---> Package atk.x86_64 0:1.30.0-1.el6 will be an update
---> Package gdk-pixbuf2.x86_64 0:2.24.1-5.el6 will be installed
---> Package glib2.x86_64 0:2.22.5-7.el6 will be updated
--> Processing Dependency: glib2 = 2.22.5-7.el6 for package: glib2-devel-2.22.5-7.el6.x86_64
---> Package glib2.x86_64 0:2.28.8-4.el6 will be an update
---> Package icedtea-web.x86_64 0:1.2.3-4.el6_4 will be updated
---> Package icedtea-web.x86_64 0:1.4.1-0.el6 will be an update
---> Package librsvg2.x86_64 0:2.26.0-5.el6_1.1 will be updated
---> Package librsvg2.x86_64 0:2.26.0-14.el6 will be an update
---> Package xpra.x86_64 0:0.10.4-2.el6_3 will be updated
---> Package xpra.x86_64 0:0.14.4-1.el6_3 will be an update
--> Processing Dependency: xorg-x11-drv-dummy for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: ffmpeg-xpra for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libswscale.so.2(LIBSWSCALE_2)(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libavutil.so.52(LIBAVUTIL_52)(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libfakeXinerama for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libavcodec.so.55(LIBAVCODEC_55)(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libwebp-xpra for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: python-netifaces for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libvpx-xpra for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: python-lz4 for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: x264-xpra for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: gtk2-immodule-xim for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libavcodec.so.55()(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libx264.so.142()(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libswscale.so.2()(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libavutil.so.52()(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
--> Processing Dependency: libwebp.so.5()(64bit) for package: xpra-0.14.4-1.el6_3.x86_64
---> Package xulrunner.x86_64 0:17.0.8-3.el6_4 will be updated
---> Package xulrunner.x86_64 0:17.0.10-1.el6_4 will be an update
--> Running transaction check
---> Package ffmpeg-xpra.x86_64 0:2.3.3-1.el6 will be installed
---> Package glib2-devel.x86_64 0:2.22.5-7.el6 will be updated
---> Package glib2-devel.x86_64 0:2.28.8-4.el6 will be an update
---> Package gtk2-immodule-xim.x86_64 0:2.24.23-6.el6 will be installed
---> Package libfakeXinerama.x86_64 0:0.1.0-3.el6 will be installed
---> Package libvpx-xpra.x86_64 0:1.3.0-1.el6 will be installed
---> Package libwebp-xpra.x86_64 0:0.4.1-1.el6 will be installed
---> Package python-lz4.x86_64 0:0.7.0-0.el6 will be installed
---> Package python-netifaces.x86_64 0:0.10.4-2.el6 will be installed
---> Package x264-xpra.x86_64 0:20140814-1.el6 will be installed
---> Package xorg-x11-drv-dummy.x86_64 0:0.3.6-15.el6 will be installed
--> Processing Dependency: xserver-abi(videodrv-15) >= 0 for package: xorg-x11-drv-dummy-0.3.6-15.el6.x86_64
--> Running transaction check
---> Package xorg-x11-server-Xorg.x86_64 0:1.13.0-11.sl6 will be updated
--> Processing Dependency: xserver-abi(videodrv-13) >= 1 for package: xorg-x11-drv-vesa-2.3.2-4.el6.x86_64
--> Processing Dependency: xserver-abi(xinput-18) >= 0 for package: xorg-x11-drv-void-1.4.0-3.el6.x86_64
--> Processing Dependency: xserver-abi(xinput-18) >= 0 for package: xorg-x11-drv-evdev-2.7.3-5.el6.x86_64
---> Package xorg-x11-server-Xorg.x86_64 0:1.15.0-22.sl6 will be an update
--> Processing Dependency: xorg-x11-server-common >= 1.15.0-22.sl6 for package: xorg-x11-server-Xorg-1.15.0-22.sl6.x86_64
--> Running transaction check
---> Package xorg-x11-drv-evdev.x86_64 0:2.7.3-5.el6 will be updated
---> Package xorg-x11-drv-evdev.x86_64 0:2.8.2-4.el6 will be an update
---> Package xorg-x11-drv-vesa.x86_64 0:2.3.2-4.el6 will be updated
---> Package xorg-x11-drv-vesa.x86_64 0:2.3.2-15.el6 will be an update
---> Package xorg-x11-drv-void.x86_64 0:1.4.0-3.el6 will be updated
---> Package xorg-x11-drv-void.x86_64 0:1.4.0-23.el6 will be an update
---> Package xorg-x11-server-common.x86_64 0:1.13.0-11.sl6 will be updated
---> Package xorg-x11-server-common.x86_64 0:1.15.0-22.sl6 will be an update
--> Processing Dependency: pixman >= 0.30.0 for package: xorg-x11-server-common-1.15.0-22.sl6.x86_64
--> Running transaction check
---> Package pixman.x86_64 0:0.26.2-5.el6_4 will be updated
---> Package pixman.x86_64 0:0.32.4-4.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================
 Package                                   Arch                      Version                              Repository                       Size
================================================================================================================================================
Updating:
 gtk2                                      x86_64                    2.24.23-6.el6                        slf-security                    3.2 M
Installing for dependencies:
 ffmpeg-xpra                               x86_64                    2.3.3-1.el6                          winswitch                       1.6 M
 gdk-pixbuf2                               x86_64                    2.24.1-5.el6                         slf-security                    500 k
 gtk2-immodule-xim                         x86_64                    2.24.23-6.el6                        slf-security                     62 k
 libfakeXinerama                           x86_64                    0.1.0-3.el6                          winswitch                       7.1 k
 libvpx-xpra                               x86_64                    1.3.0-1.el6                          winswitch                       721 k
 libwebp-xpra                              x86_64                    0.4.1-1.el6                          winswitch                       684 k
 python-lz4                                x86_64                    0.7.0-0.el6                          winswitch                        22 k
 python-netifaces                          x86_64                    0.10.4-2.el6                         winswitch                        31 k
 x264-xpra                                 x86_64                    20140814-1.el6                       winswitch                       523 k
 xorg-x11-drv-dummy                        x86_64                    0.3.6-15.el6                         slf-security                     13 k
Updating for dependencies:
 atk                                       x86_64                    1.30.0-1.el6                         slf-security                    195 k
 glib2                                     x86_64                    2.28.8-4.el6                         slf-security                    1.7 M
 glib2-devel                               x86_64                    2.28.8-4.el6                         slf-security                    298 k
 icedtea-web                               x86_64                    1.4.1-0.el6                          slf-security                    914 k
 librsvg2                                  x86_64                    2.26.0-14.el6                        slf-security                    139 k
 pixman                                    x86_64                    0.32.4-4.el6                         slf-security                    242 k
 xorg-x11-drv-evdev                        x86_64                    2.8.2-4.el6                          slf-security                     40 k
 xorg-x11-drv-vesa                         x86_64                    2.3.2-15.el6                         slf-security                     21 k
 xorg-x11-drv-void                         x86_64                    1.4.0-23.el6                         slf-security                     12 k
 xorg-x11-server-Xorg                      x86_64                    1.15.0-22.sl6                        slf-security                    1.3 M
 xorg-x11-server-common                    x86_64                    1.15.0-22.sl6                        slf-security                     48 k
 xpra                                      x86_64                    0.14.4-1.el6_3                       winswitch                       2.5 M
 xulrunner                                 x86_64                    17.0.10-1.el6_4                      slf-security                     14 M

Transaction Summary
================================================================================================================================================
Install      10 Package(s)
Upgrade      14 Package(s)

Total download size: 29 M
Is this ok [y/N]: y
Downloading Packages:
(1/24): atk-1.30.0-1.el6.x86_64.rpm                                                                                      | 195 kB     00:00     
(2/24): ffmpeg-xpra-2.3.3-1.el6.x86_64.rpm                                                                               | 1.6 MB     00:06     
(3/24): gdk-pixbuf2-2.24.1-5.el6.x86_64.rpm                                                                              | 500 kB     00:00     
(4/24): glib2-2.28.8-4.el6.x86_64.rpm                                                                                    | 1.7 MB     00:00     
(5/24): glib2-devel-2.28.8-4.el6.x86_64.rpm                                                                              | 298 kB     00:00     
(6/24): gtk2-2.24.23-6.el6.x86_64.rpm                                                                                    | 3.2 MB     00:00     
(7/24): gtk2-immodule-xim-2.24.23-6.el6.x86_64.rpm                                                                       |  62 kB     00:00     
(8/24): icedtea-web-1.4.1-0.el6.x86_64.rpm                                                                               | 914 kB     00:00     
(9/24): libfakeXinerama-0.1.0-3.el6.x86_64.rpm                                                                           | 7.1 kB     00:00     
(10/24): librsvg2-2.26.0-14.el6.x86_64.rpm                                                                               | 139 kB     00:00     
(11/24): libvpx-xpra-1.3.0-1.el6.x86_64.rpm                                                                              | 721 kB     00:00     
(12/24): libwebp-xpra-0.4.1-1.el6.x86_64.rpm                                                                             | 684 kB     00:00     
(13/24): pixman-0.32.4-4.el6.x86_64.rpm                                                                                  | 242 kB     00:00     
(14/24): python-lz4-0.7.0-0.el6.x86_64.rpm                                                                               |  22 kB     00:00     
(15/24): python-netifaces-0.10.4-2.el6.x86_64.rpm                                                                        |  31 kB     00:00     
(16/24): x264-xpra-20140814-1.el6.x86_64.rpm                                                                             | 523 kB     00:00     
(17/24): xorg-x11-drv-dummy-0.3.6-15.el6.x86_64.rpm                                                                      |  13 kB     00:00     
(18/24): xorg-x11-drv-evdev-2.8.2-4.el6.x86_64.rpm                                                                       |  40 kB     00:00     
(19/24): xorg-x11-drv-vesa-2.3.2-15.el6.x86_64.rpm                                                                       |  21 kB     00:00     
(20/24): xorg-x11-drv-void-1.4.0-23.el6.x86_64.rpm                                                                       |  12 kB     00:00     
(21/24): xorg-x11-server-Xorg-1.15.0-22.sl6.x86_64.rpm                                                                   | 1.3 MB     00:00     
(22/24): xorg-x11-server-common-1.15.0-22.sl6.x86_64.rpm                                                                 |  48 kB     00:00     
(23/24): xpra-0.14.4-1.el6_3.x86_64.rpm                                                                                  | 2.5 MB     00:05     
(24/24): xulrunner-17.0.10-1.el6_4.x86_64.rpm                                                                            |  14 MB     00:01     
------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                           1.1 MB/s |  29 MB     00:25     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : glib2-2.28.8-4.el6.x86_64                                                                                                   1/38 
  Installing : gdk-pixbuf2-2.24.1-5.el6.x86_64                                                                                             2/38 
  Updating   : atk-1.30.0-1.el6.x86_64                                                                                                     3/38 
  Updating   : gtk2-2.24.23-6.el6.x86_64                                                                                                   4/38 
  Updating   : pixman-0.32.4-4.el6.x86_64                                                                                                  5/38 
  Updating   : xorg-x11-server-common-1.15.0-22.sl6.x86_64                                                                                 6/38 
  Updating   : xorg-x11-server-Xorg-1.15.0-22.sl6.x86_64                                                                                   7/38 
  Installing : xorg-x11-drv-dummy-0.3.6-15.el6.x86_64                                                                                      8/38 
  Updating   : xorg-x11-drv-void-1.4.0-23.el6.x86_64                                                                                       9/38 
  Installing : gtk2-immodule-xim-2.24.23-6.el6.x86_64                                                                                     10/38 
  Installing : x264-xpra-20140814-1.el6.x86_64                                                                                            11/38 
  Installing : python-netifaces-0.10.4-2.el6.x86_64                                                                                       12/38 
  Installing : libvpx-xpra-1.3.0-1.el6.x86_64                                                                                             13/38 
  Installing : libfakeXinerama-0.1.0-3.el6.x86_64                                                                                         14/38 
  Installing : ffmpeg-xpra-2.3.3-1.el6.x86_64                                                                                             15/38 
  Installing : libwebp-xpra-0.4.1-1.el6.x86_64                                                                                            16/38 
  Installing : python-lz4-0.7.0-0.el6.x86_64                                                                                              17/38 
  Updating   : xpra-0.14.4-1.el6_3.x86_64                                                                                                 18/38 
  Updating   : xorg-x11-drv-evdev-2.8.2-4.el6.x86_64                                                                                      19/38 
  Updating   : xorg-x11-drv-vesa-2.3.2-15.el6.x86_64                                                                                      20/38 
  Updating   : librsvg2-2.26.0-14.el6.x86_64                                                                                              21/38 
  Updating   : xulrunner-17.0.10-1.el6_4.x86_64                                                                                           22/38 
  Updating   : icedtea-web-1.4.1-0.el6.x86_64                                                                                             23/38 
  Updating   : glib2-devel-2.28.8-4.el6.x86_64                                                                                            24/38 
  Cleanup    : librsvg2-2.26.0-5.el6_1.1.x86_64                                                                                           25/38 
  Cleanup    : xulrunner-17.0.8-3.el6_4.x86_64                                                                                            26/38 
  Cleanup    : icedtea-web-1.2.3-4.el6_4.x86_64                                                                                           27/38 
  Cleanup    : xpra-0.10.4-2.el6_3.x86_64                                                                                                 28/38 
  Cleanup    : gtk2-2.18.9-10.el6.x86_64                                                                                                  29/38 
  Cleanup    : atk-1.28.0-2.el6.x86_64                                                                                                    30/38 
  Cleanup    : xorg-x11-drv-evdev-2.7.3-5.el6.x86_64                                                                                      31/38 
  Cleanup    : xorg-x11-drv-vesa-2.3.2-4.el6.x86_64                                                                                       32/38 
  Cleanup    : xorg-x11-server-Xorg-1.13.0-11.sl6.x86_64                                                                                  33/38 
  Cleanup    : xorg-x11-drv-void-1.4.0-3.el6.x86_64                                                                                       34/38 
  Cleanup    : xorg-x11-server-common-1.13.0-11.sl6.x86_64                                                                                35/38 
  Cleanup    : glib2-devel-2.22.5-7.el6.x86_64                                                                                            36/38 
  Cleanup    : glib2-2.22.5-7.el6.x86_64                                                                                                  37/38 
  Cleanup    : pixman-0.26.2-5.el6_4.x86_64                                                                                               38/38 
  Verifying  : python-lz4-0.7.0-0.el6.x86_64                                                                                               1/38 
  Verifying  : libwebp-xpra-0.4.1-1.el6.x86_64                                                                                             2/38 
  Verifying  : librsvg2-2.26.0-14.el6.x86_64                                                                                               3/38 
  Verifying  : gdk-pixbuf2-2.24.1-5.el6.x86_64                                                                                             4/38 
  Verifying  : xorg-x11-drv-dummy-0.3.6-15.el6.x86_64                                                                                      5/38 
  Verifying  : pixman-0.32.4-4.el6.x86_64                                                                                                  6/38 
  Verifying  : gtk2-immodule-xim-2.24.23-6.el6.x86_64                                                                                      7/38 
  Verifying  : xorg-x11-drv-void-1.4.0-23.el6.x86_64                                                                                       8/38 
  Verifying  : ffmpeg-xpra-2.3.3-1.el6.x86_64                                                                                              9/38 
  Verifying  : xpra-0.14.4-1.el6_3.x86_64                                                                                                 10/38 
  Verifying  : glib2-2.28.8-4.el6.x86_64                                                                                                  11/38 
  Verifying  : icedtea-web-1.4.1-0.el6.x86_64                                                                                             12/38 
  Verifying  : xorg-x11-server-Xorg-1.15.0-22.sl6.x86_64                                                                                  13/38 
  Verifying  : libfakeXinerama-0.1.0-3.el6.x86_64                                                                                         14/38 
  Verifying  : libvpx-xpra-1.3.0-1.el6.x86_64                                                                                             15/38 
  Verifying  : gtk2-2.24.23-6.el6.x86_64                                                                                                  16/38 
  Verifying  : python-netifaces-0.10.4-2.el6.x86_64                                                                                       17/38 
  Verifying  : x264-xpra-20140814-1.el6.x86_64                                                                                            18/38 
  Verifying  : xorg-x11-drv-evdev-2.8.2-4.el6.x86_64                                                                                      19/38 
  Verifying  : glib2-devel-2.28.8-4.el6.x86_64                                                                                            20/38 
  Verifying  : atk-1.30.0-1.el6.x86_64                                                                                                    21/38 
  Verifying  : xulrunner-17.0.10-1.el6_4.x86_64                                                                                           22/38 
  Verifying  : xorg-x11-drv-vesa-2.3.2-15.el6.x86_64                                                                                      23/38 
  Verifying  : xorg-x11-server-common-1.15.0-22.sl6.x86_64                                                                                24/38 
  Verifying  : xorg-x11-drv-void-1.4.0-3.el6.x86_64                                                                                       25/38 
  Verifying  : atk-1.28.0-2.el6.x86_64                                                                                                    26/38 
  Verifying  : icedtea-web-1.2.3-4.el6_4.x86_64                                                                                           27/38 
  Verifying  : xulrunner-17.0.8-3.el6_4.x86_64                                                                                            28/38 
  Verifying  : glib2-2.22.5-7.el6.x86_64                                                                                                  29/38 
  Verifying  : xpra-0.10.4-2.el6_3.x86_64                                                                                                 30/38 
  Verifying  : xorg-x11-server-Xorg-1.13.0-11.sl6.x86_64                                                                                  31/38 
  Verifying  : xorg-x11-server-common-1.13.0-11.sl6.x86_64                                                                                32/38 
  Verifying  : xorg-x11-drv-vesa-2.3.2-4.el6.x86_64                                                                                       33/38 
  Verifying  : librsvg2-2.26.0-5.el6_1.1.x86_64                                                                                           34/38 
  Verifying  : xorg-x11-drv-evdev-2.7.3-5.el6.x86_64                                                                                      35/38 
  Verifying  : gtk2-2.18.9-10.el6.x86_64                                                                                                  36/38 
  Verifying  : glib2-devel-2.22.5-7.el6.x86_64                                                                                            37/38 
  Verifying  : pixman-0.26.2-5.el6_4.x86_64                                                                                               38/38 

Dependency Installed:
  ffmpeg-xpra.x86_64 0:2.3.3-1.el6                gdk-pixbuf2.x86_64 0:2.24.1-5.el6             gtk2-immodule-xim.x86_64 0:2.24.23-6.el6       
  libfakeXinerama.x86_64 0:0.1.0-3.el6            libvpx-xpra.x86_64 0:1.3.0-1.el6              libwebp-xpra.x86_64 0:0.4.1-1.el6              
  python-lz4.x86_64 0:0.7.0-0.el6                 python-netifaces.x86_64 0:0.10.4-2.el6        x264-xpra.x86_64 0:20140814-1.el6              
  xorg-x11-drv-dummy.x86_64 0:0.3.6-15.el6       

Updated:
  gtk2.x86_64 0:2.24.23-6.el6                                                                                                                   

Dependency Updated:
  atk.x86_64 0:1.30.0-1.el6                       glib2.x86_64 0:2.28.8-4.el6                       glib2-devel.x86_64 0:2.28.8-4.el6          
  icedtea-web.x86_64 0:1.4.1-0.el6                librsvg2.x86_64 0:2.26.0-14.el6                   pixman.x86_64 0:0.32.4-4.el6               
  xorg-x11-drv-evdev.x86_64 0:2.8.2-4.el6         xorg-x11-drv-vesa.x86_64 0:2.3.2-15.el6           xorg-x11-drv-void.x86_64 0:1.4.0-23.el6    
  xorg-x11-server-Xorg.x86_64 0:1.15.0-22.sl6     xorg-x11-server-common.x86_64 0:1.15.0-22.sl6     xpra.x86_64 0:0.14.4-1.el6_3               
  xulrunner.x86_64 0:17.0.10-1.el6_4             

Complete!

Started apache on dsfr6

As root...

(Since this node is on a private network, I felt that it was OK to run this web server for short periods of time with its default configuration.)

Installed Ganglia

[root@dsfr6 ~]# yum --enablerepo=epel install ganglia-gmond ganglia-gmetad ganglia-web
Loaded plugins: auto-update-debuginfo, fastestmirror, protectbase, security
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                            |  15 kB     00:00     
epel-debuginfo/metalink                                                                                                  |  13 kB     00:00     
 * epel: archive.linux.duke.edu
 * epel-debuginfo: archive.linux.duke.edu
epel                                                                                                                     | 4.4 kB     00:00     
epel/primary_db                                                                                                          | 6.4 MB     00:15     
epel-debuginfo                                                                                                           | 3.0 kB     00:00     
epel-debuginfo/primary_db                                                                                                | 669 kB     00:00     
slf                                                                                                                      | 3.5 kB     00:00     
slf-debuginfo                                                                                                            | 2.6 kB     00:00     
slf-debuginfo/primary_db                                                                                                 | 2.8 MB     00:00     
slf-security                                                                                                             | 3.0 kB     00:00     
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ganglia-gmetad.x86_64 0:3.1.7-6.el6 will be installed
--> Processing Dependency: ganglia = 3.1.7-6.el6 for package: ganglia-gmetad-3.1.7-6.el6.x86_64
--> Processing Dependency: librrd.so.4()(64bit) for package: ganglia-gmetad-3.1.7-6.el6.x86_64
--> Processing Dependency: libganglia-3.1.7.so.0()(64bit) for package: ganglia-gmetad-3.1.7-6.el6.x86_64
--> Processing Dependency: libconfuse.so.0()(64bit) for package: ganglia-gmetad-3.1.7-6.el6.x86_64
---> Package ganglia-gmond.x86_64 0:3.1.7-6.el6 will be installed
---> Package ganglia-web.x86_64 0:3.1.7-6.el6 will be installed
--> Processing Dependency: php-gd for package: ganglia-web-3.1.7-6.el6.x86_64
--> Processing Dependency: php for package: ganglia-web-3.1.7-6.el6.x86_64
--> Running transaction check
---> Package ganglia.x86_64 0:3.1.7-6.el6 will be installed
---> Package libconfuse.x86_64 0:2.7-4.el6 will be installed
---> Package php.x86_64 0:5.3.3-40.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-40.el6_6 for package: php-5.3.3-40.el6_6.x86_64
--> Processing Dependency: php-cli(x86-64) = 5.3.3-40.el6_6 for package: php-5.3.3-40.el6_6.x86_64
---> Package php-gd.x86_64 0:5.3.3-40.el6_6 will be installed
---> Package rrdtool.x86_64 0:1.3.8-6.el6 will be installed
--> Processing Dependency: dejavu-sans-mono-fonts for package: rrdtool-1.3.8-6.el6.x86_64
--> Processing Dependency: dejavu-lgc-sans-mono-fonts for package: rrdtool-1.3.8-6.el6.x86_64
--> Running transaction check
---> Package dejavu-lgc-sans-mono-fonts.noarch 0:2.30-2.el6 will be installed
---> Package dejavu-sans-mono-fonts.noarch 0:2.30-2.el6 will be installed
---> Package php-cli.x86_64 0:5.3.3-40.el6_6 will be installed
---> Package php-common.x86_64 0:5.3.3-40.el6_6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================
 Package                                      Arch                     Version                             Repository                      Size
================================================================================================================================================
Installing:
 ganglia-gmetad                               x86_64                   3.1.7-6.el6                         epel                            34 k
 ganglia-gmond                                x86_64                   3.1.7-6.el6                         epel                            56 k
 ganglia-web                                  x86_64                   3.1.7-6.el6                         epel                           113 k
Installing for dependencies:
 dejavu-lgc-sans-mono-fonts                   noarch                   2.30-2.el6                          slf                            392 k
 dejavu-sans-mono-fonts                       noarch                   2.30-2.el6                          slf                            449 k
 ganglia                                      x86_64                   3.1.7-6.el6                         epel                           150 k
 libconfuse                                   x86_64                   2.7-4.el6                           epel                            79 k
 php                                          x86_64                   5.3.3-40.el6_6                      slf-security                   1.1 M
 php-cli                                      x86_64                   5.3.3-40.el6_6                      slf-security                   2.2 M
 php-common                                   x86_64                   5.3.3-40.el6_6                      slf-security                   526 k
 php-gd                                       x86_64                   5.3.3-40.el6_6                      slf-security                   108 k
 rrdtool                                      x86_64                   1.3.8-6.el6                         slf                            292 k

Transaction Summary
================================================================================================================================================
Install      12 Package(s)

Total download size: 5.5 M
Installed size: 17 M
Is this ok [y/N]: y
Downloading Packages:
(1/12): dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch.rpm                                                                 | 392 kB     00:00     
(2/12): dejavu-sans-mono-fonts-2.30-2.el6.noarch.rpm                                                                     | 449 kB     00:00     
(3/12): ganglia-3.1.7-6.el6.x86_64.rpm                                                                                   | 150 kB     00:00     
(4/12): ganglia-gmetad-3.1.7-6.el6.x86_64.rpm                                                                            |  34 kB     00:00     
(5/12): ganglia-gmond-3.1.7-6.el6.x86_64.rpm                                                                             |  56 kB     00:00     
(6/12): ganglia-web-3.1.7-6.el6.x86_64.rpm                                                                               | 113 kB     00:00     
(7/12): libconfuse-2.7-4.el6.x86_64.rpm                                                                                  |  79 kB     00:00     
(8/12): php-5.3.3-40.el6_6.x86_64.rpm                                                                                    | 1.1 MB     00:00     
(9/12): php-cli-5.3.3-40.el6_6.x86_64.rpm                                                                                | 2.2 MB     00:00     
(10/12): php-common-5.3.3-40.el6_6.x86_64.rpm                                                                            | 526 kB     00:00     
(11/12): php-gd-5.3.3-40.el6_6.x86_64.rpm                                                                                | 108 kB     00:00     
(12/12): rrdtool-1.3.8-6.el6.x86_64.rpm                                                                                  | 292 kB     00:00     
------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                           710 kB/s | 5.5 MB     00:07     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : php-common-5.3.3-40.el6_6.x86_64                                                                                            1/12 
  Installing : libconfuse-2.7-4.el6.x86_64                                                                                                 2/12 
  Installing : ganglia-3.1.7-6.el6.x86_64                                                                                                  3/12 
  Installing : php-cli-5.3.3-40.el6_6.x86_64                                                                                               4/12 
  Installing : php-5.3.3-40.el6_6.x86_64                                                                                                   5/12 
  Installing : php-gd-5.3.3-40.el6_6.x86_64                                                                                                6/12 
  Installing : dejavu-sans-mono-fonts-2.30-2.el6.noarch                                                                                    7/12 
  Installing : dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch                                                                                8/12 
  Installing : rrdtool-1.3.8-6.el6.x86_64                                                                                                  9/12 
  Installing : ganglia-gmetad-3.1.7-6.el6.x86_64                                                                                          10/12 
  Installing : ganglia-web-3.1.7-6.el6.x86_64                                                                                             11/12 
  Installing : ganglia-gmond-3.1.7-6.el6.x86_64                                                                                           12/12 
  Verifying  : php-cli-5.3.3-40.el6_6.x86_64                                                                                               1/12 
  Verifying  : dejavu-lgc-sans-mono-fonts-2.30-2.el6.noarch                                                                                2/12 
  Verifying  : ganglia-3.1.7-6.el6.x86_64                                                                                                  3/12 
  Verifying  : libconfuse-2.7-4.el6.x86_64                                                                                                 4/12 
  Verifying  : rrdtool-1.3.8-6.el6.x86_64                                                                                                  5/12 
  Verifying  : dejavu-sans-mono-fonts-2.30-2.el6.noarch                                                                                    6/12 
  Verifying  : ganglia-web-3.1.7-6.el6.x86_64                                                                                              7/12 
  Verifying  : ganglia-gmond-3.1.7-6.el6.x86_64                                                                                            8/12 
  Verifying  : ganglia-gmetad-3.1.7-6.el6.x86_64                                                                                           9/12 
  Verifying  : php-5.3.3-40.el6_6.x86_64                                                                                                  10/12 
  Verifying  : php-gd-5.3.3-40.el6_6.x86_64                                                                                               11/12 
  Verifying  : php-common-5.3.3-40.el6_6.x86_64                                                                                           12/12 

Installed:
  ganglia-gmetad.x86_64 0:3.1.7-6.el6              ganglia-gmond.x86_64 0:3.1.7-6.el6              ganglia-web.x86_64 0:3.1.7-6.el6             

Dependency Installed:
  dejavu-lgc-sans-mono-fonts.noarch 0:2.30-2.el6        dejavu-sans-mono-fonts.noarch 0:2.30-2.el6        ganglia.x86_64 0:3.1.7-6.el6          
  libconfuse.x86_64 0:2.7-4.el6                         php.x86_64 0:5.3.3-40.el6_6                       php-cli.x86_64 0:5.3.3-40.el6_6       
  php-common.x86_64 0:5.3.3-40.el6_6                    php-gd.x86_64 0:5.3.3-40.el6_6                    rrdtool.x86_64 0:1.3.8-6.el6          

Complete!

Configured and started Ganglia

  • 'gmond -t > /etc/gmond.conf'
  • '/etc/init.d/gmond restart'
    • problems connecting to a multicast address
    • ran 'route add -host 239.2.11.71 dev eth1'
    • then ganglia startup worked
  • Modified the cluster name in /etc/gmond.conf
    • "DS-50 WH14NE Teststand"
  • Modified the data_source in /etc/ganglia/gmetad.conf
    • "DS-50 WH14NE Teststand"
  • 'service gmetad start'
When I tried to build the artdaq_ganglia_plugin software package on dsfr6, I found that we need to install a couple of "development" RPMs:
  • 'yum --enablerepo=epel install libconfuse-devel'
  • 'yum --enablerepo=epel install apr-devel'
  • 'yum --enablerepo=epel install ganglia-devel'

Starting and stopping servers

  • '/etc/init.d/gmond start/stop/status'
  • 'service gmetad start/stop/status'
  • 'apachectl start/stop/status'