Project

General

Profile

Feature #9803

Input files with no events

Added by G2Muon G2Muon almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Metadata
Target version:
-
Start date:
08/10/2015
Due date:
% Done:

0%

Estimated time:
Spent time:
Scope:
Internal
Experiment:
g-2
SSI Package:
art
Duration:

Description

Brief description:
When running on a series of art files, if one containing no events is found, an error is thrown that there are different structures in the root files. I've then had to remove this run from the run list by hand.

Longer description:
I've been running on a set of test beam data where different hardware configurations are used for small runs containing ~15 events. Namely, a discriminator threhold is changed for each run.

The data is passed through a cleaning module which can remove events if there is a problem - e.g. if the beam went down or the triggers went out of sync. For a small fraction of runs, all data is bad and we end up with a run with no Art events. In this scenario, the structures from the previous modules in the chain aren't passed down - only the new Art records are added.

If this run happens to fall at the start of my list of files, then I get an error on encountering the first non-empty file of the form:

%MSG-s ArtException: PostCloseFile 10-Aug-2015 14:43:33 CDT PostEndRun
cet::exception caught in art
---- MismatchedInputFiles BEGIN
RootInputFileSequence::mergeMPR() Branch 'gm2strawtracker::GLIBTriggerArtRecords_getGLIBTriggers_straws_SyncTimings.' is in file 'mtestRawtoDigits_00358.root'
but not in previous files.

If the empty file is not in the first file, then the files are all processed.

Obviously, I'm not going to do too much with an empty file, but it would be nice if I didn't have to go and remove these from my list of runs by hand based on this error. Is it possible to add a feature so that an empty file is not taken into account when searching for this type of error?


Related issues

Is duplicate of art - Bug #2695: support for filtered datasetsClosed

History

#1 Updated by Christopher Green almost 4 years ago

  • Category set to Metadata
  • Status changed from New to Feedback
  • SSI Package art added
  • SSI Package deleted ()

We will investigate this behavior. Could you please tell us with which version of art you are experiencing this problem?

#2 Updated by Andrei Gaponenko almost 4 years ago

This is an issue for Mu2e as well. See https://cdcvs.fnal.gov/redmine/issues/2695
Andrei

#3 Updated by Kyle Knoepfel almost 4 years ago

  • Is duplicate of Bug #2695: support for filtered datasets added

#4 Updated by Kyle Knoepfel almost 4 years ago

  • Status changed from Feedback to Rejected

This issue has been rejected because it duplicates bug #2695. Note that we have investigated this behavior, we understand the issue at hand, and a fix is nearly in place. Refer to the #2695 for more information.



Also available in: Atom PDF