Project

General

Profile

Bug #972

nova job crashes on trying to convert a raw datafile

Added by Peter Shanahan almost 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Category:
Metadata
Target version:
Start date:
02/14/2011
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

I tried to convert a raw data file I had copied to my data area
( /nova/app/users/shanahan/data/raw ). I changed the DAQFile parameter
in the rawtorootconvert.fcl file appropriately. I have no problem with
the original version of this fcl file.

This crashes with the following result. Two notes:

1) I really can't tell why it crashed from the message.
2) I don't know why a non-existent path (on this machine) to Chris Green's home area is referenced.

Another NOvA collaborator tried the same from her own test release, to the same effect.

<novagpvm02> nova c job/rawtorootconvert.fcl -o ../../data/art/ndos_r00011495_s00.root
----------------------

DCM Simulator Version 1098272590
-----------------------
nova: /home/greenc/work/cet-is/art-devel/art/Framework/Core/EPStates.cc:672: bool statemachine::FirstSubRun::checkInvariant(): Assertion `context<HandleSubRuns>().currentSubRun().second != INVALID_LUMI' failed.
Abort


Related issues

Is duplicate of art - Bug #959: Raw to root files conversion failsClosed02/11/2011

History

#1 Updated by Christopher Green almost 10 years ago

  • Category set to Metadata

This is a duplicate of issue #959 and is a known consequence of the fact that the NOvA DAQ uses 0 as the first subrun; and the framework was designed to treat 00 as an unset, invalid value. A solution has been proposed and will be implemented shortly.

Sorry for the inconvenience.

#2 Updated by Marc Paterno almost 10 years ago

  • Status changed from New to Assigned

Status changed to Assigned

#3 Updated by Christopher Green almost 10 years ago

  • Status changed from Assigned to Feedback
  • Priority changed from Normal to High
  • % Done changed from 0 to 90

Hi Peter,

I have a solution ready to merge into the ART code, but when testing it against NOvA raw data to make sure a conversion actually works, I received the following message on STDERR after running for just a hair short of twelve minutes.:

FlatReadModule: Found the run tail! Aborting!

Is this good or bad? If bad, do you have any idea what might be wrong?

Thanks for your help,
Chris.

#4 Updated by Christopher Green almost 10 years ago

  • Target version set to 0.5.0

This issue is resolved and will be released with ART v0.5.0.

See issue #959 for further details.

#5 Updated by Christopher Green almost 10 years ago

  • Status changed from Feedback to Resolved

#6 Updated by Christopher Green almost 10 years ago

  • Status changed from Resolved to Reviewed
  • % Done changed from 90 to 100

#7 Updated by Christopher Green over 9 years ago

  • Status changed from Reviewed to Closed

Also available in: Atom PDF