Project

General

Profile

Bug #938

code in art should not be directly throwing cet::exception; use art::Exception

Added by Marc Paterno over 8 years ago. Updated about 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
-
Start date:
02/07/2011
Due date:
% Done:

0%

Estimated time:
Occurs In:
Scope:
Experiment:
SSI Package:
Duration:

Description

There are many places in the art code where instances of class cet::exception are thrown. Code in art should instead be throwing instances of art::Exception, using an appropriate value from art::errors::ErrorCodes to denote the exception's category. This will make our error messages, and configuration of the error handling facilities, more straightforward.


Related issues

Is duplicate of art - Necessary Maintenance #907: Review and rationalize use of exceptions across art.Accepted02/01/201109/30/2013

History

#1 Updated by Christopher Green over 8 years ago

  • Category set to Infrastructure
  • Priority changed from High to Normal

#2 Updated by Walter E Brown almost 8 years ago

  • Status changed from New to Accepted

#3 Updated by Christopher Green about 6 years ago

  • Status changed from Accepted to Rejected

Rejected as a duplicate.



Also available in: Atom PDF