Project

General

Profile

Bug #930

ArtException says can't load library when it really means illegal module name

Added by Brian Rebel over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Category:
Infrastructure
Target version:
Start date:
02/04/2011
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

The following exception was thrown when a user tried to make an EDProducer with an underscore in its name:

%MSG-s ArtException: MergeData_Beam:beam@Construction 04-Feb-2011 08:30:37 CST MF-online
cet::exception caught in art
---- Configuration BEGIN
UnknownModule ---- Library specificaton "MergeData_Beam": does not correspond to any library in LD_LIBRARY_PATH of type "module"
BEGIN
---- Library specificaton "MergeData_Beam": does not correspond to any library in LD_LIBRARY_PATH of type "module"
END
Module MergeData_Beam with version v0_4_1 was not registered.
Perhaps your module type is misspelled or is not a framework plugin.
---- Configuration END

A more helpful error message would have been to say that modules can't have underscores in their names, as a check of the LD_LIBRARY_PATH revealed that the library really did exist.

Associated revisions

Revision 8fb51fa5 (diff)
Added by Christopher Green over 9 years ago

Fix and test for issue #930.

History

#1 Updated by Christopher Green over 9 years ago

  • Category set to Infrastructure
  • Status changed from New to Assigned
  • Assignee set to Christopher Green

#2 Updated by Christopher Green over 9 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 0.5.0
  • % Done changed from 0 to 100

Fixed with commit 8fb51fa.

#3 Updated by Marc Paterno over 9 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF