Project

General

Profile

Bug #922

Command line input for fhicl file does not appear to be using FHICL_FILE_PATH

Added by Brian Rebel over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Category:
Infrastructure
Target version:
Start date:
02/03/2011
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

when running nova jobs of the following form

nova -c job/evd.fcl -s somefile.root

It has been observed that unless the user has a job/evd.fcl file in the current directory the job fails with the message
"Specified configuration file job/evd.fcl cannot be opened for reading"

It appears that the problem is that the $FHICL_FILE_PATH is not being used to find the configuration file specified on the command line.

History

#1 Updated by Walter E Brown over 9 years ago

  • Category set to Infrastructure
  • Status changed from New to Assigned
  • Assignee set to Walter E Brown

#2 Updated by Walter E Brown over 9 years ago

Fixed in cetlib v0_4_1

#3 Updated by Walter E Brown over 9 years ago

  • Status changed from Assigned to Resolved

Next release of art (and of its dependent libraries) will require cetlib v0_4_1

#4 Updated by Christopher Green over 9 years ago

  • Target version set to 0.4.2
  • % Done changed from 0 to 100

#5 Updated by Christopher Green over 9 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF