Project

General

Profile

Feature #8987

sam_metadata_dumper should only write the basename into the JSON output

Added by Christopher Backhouse over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Application
Target version:
Start date:
05/29/2015
Due date:
% Done:

100%

Estimated time:
1.00 h
Spent time:
Scope:
Internal
Experiment:
NOvA
SSI Package:
art
Duration:

Description

bckhouse@novagpvm02:/nova/app/users$ sam_metadata_dumper bckhouse/fardet_r00013061_s15_t00_S15-03-11_v1_data.artdaq.root
{
  "bckhouse/fardet_r00013061_s15_t00_S15-03-11_v1_data.artdaq.root": {
  "applicationFamily": "nova",
   "applicationVersion": "S15-03-11",
...

I would argue that that first line, the key that the rest of the metadata is the value for, should have had basename() run over it. SAM is only interested in the filenames themselves, and it should be possible to extract the metadata of a file while in a directory other than the one that it's in.

History

#1 Updated by Christopher Green over 4 years ago

  • Tracker changed from Bug to Feature
  • Category set to Application
  • Status changed from New to Feedback
  • Estimated time set to 1.00 h
  • SSI Package art added
  • SSI Package deleted ()

Since this is a requested change in currently-intended behavior, we would like to discuss this at an upcoming stakeholders meeting.

#2 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Feedback to Accepted

Accepted per stakeholder discussion.

#3 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Accepted to Resolved
  • Assignee set to Kyle Knoepfel
  • Target version set to 2.01.00
  • % Done changed from 0 to 100

Implemented with commit art:001f5212.

#4 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF