Project

General

Profile

Milestone #896

Feature #8593: Improve flexibility of output file handling

Design and specify maxEvents for output streams

Added by Christopher Green almost 9 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
I/O
Target version:
Start date:
02/01/2011
Due date:
01/01/2014
% Done:

100%

Estimated time:
0.00 h
Spent time:
Experiment:
-
Duration: 1066

limitOutput.cc (1.43 KB) limitOutput.cc current implementation of Schedule::limitOutput Marc Paterno, 02/10/2011 01:22 PM

Related issues

Has duplicate art - Bug #1057: Specifying maximum output file size does not workRejected

Has duplicate art - Feature #3773: Improved ability to control when RootOutput will close and open output files.Rejected04/26/2013

History

#1 Updated by Marc Paterno almost 9 years ago

The Schedule::limitOutput function is currently ifdef'd into a no-op. I have now removed the ifdef'd code. The attached file is the contents of this function, before removal of the ifdef'd code.

#2 Updated by Walter E Brown about 8 years ago

Confirmed, but must wait for the great I/O revolution.

#3 Updated by Christopher Green over 6 years ago

  • Due date set to 09/30/2013
  • Target version set to 1.09.00
  • Estimated time set to 160.00 h
  • Scope set to Internal
  • Experiment - added

This will need significant analysis due to various assumptions made in the framework about the "push" nature of output file closure.

Online applications might prefer a streaming file format, which would satisfy several of the customers for this feature (possibly Darkside online, NOvA DDT).

#4 Updated by Christopher Green over 6 years ago

  • Tracker changed from Feature to Milestone

#5 Updated by Christopher Green over 6 years ago

  • Due date changed from 09/30/2013 to 01/01/2014
  • Target version changed from 1.09.00 to 2.01.00

#6 Updated by Christopher Green over 4 years ago

  • Target version changed from 2.01.00 to 1.18.00

#7 Updated by Christopher Green over 4 years ago

#8 Updated by Christopher Green over 4 years ago

  • Blocks deleted (Milestone #3708: Implement condition-based output file rollover)

#9 Updated by Christopher Green over 4 years ago

  • Parent task set to #8593

#10 Updated by Christopher Green over 4 years ago

  • Estimated time changed from 160.00 h to 0.00 h

This issue will require the, "push" nature of the state machine input / output system to be changed. An estimate for the implementation of this particular issue given that change is pending.

#11 Updated by Christopher Green about 4 years ago

  • Target version changed from 1.18.00 to 834

#12 Updated by Marc Paterno about 4 years ago

  • Target version changed from 834 to 3.12.06

#13 Updated by Christopher Green about 4 years ago

  • Target version changed from 3.12.06 to 521

#14 Updated by Kyle Knoepfel almost 4 years ago

  • Assignee set to Kyle Knoepfel
  • Target version changed from 521 to 2.01.00

#15 Updated by Kyle Knoepfel over 3 years ago

  • % Done changed from 0 to 100

Implemented with commit art:09d893e as a specific instance of condition-based output-file rollover. RootOutput now has a parameter called maxEventsPerFile.

#16 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Accepted to Resolved

#17 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF