Project

General

Profile

Bug #879

Possible corruption in exception wrapping due to incautious use of const ref

Added by Christopher Green over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Category:
Infrastructure
Target version:
Start date:
01/31/2011
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

Symptoms of stream corruption in error messages seem empirically to have more to do with possible corruption of the exception itself than threading issues causing stream corruption. Do some investigation to ascertain if this is in fact the real problem.


Related issues

Blocked by cetlib - Bug #886: Message corruption caused by too-short lifetime of string returned by cet::exception::what()Closed01/31/2011

History

#1 Updated by Christopher Green over 8 years ago

  • Status changed from Assigned to Resolved

Resolved with resolution of #886.

#2 Updated by Christopher Green over 8 years ago

  • Category set to Infrastructure
  • Target version set to 0.4.1
  • % Done changed from 0 to 100

#3 Updated by Christopher Green over 8 years ago

  • Status changed from Resolved to Reviewed

#4 Updated by Christopher Green over 8 years ago

  • Status changed from Reviewed to Closed


Also available in: Atom PDF