Project

General

Profile

Necessary Maintenance #8713

PROLOG items in intermediate_table should be ignored during all command-line checks.

Added by Christopher Green over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
05/11/2015
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Scope:
Internal
Experiment:
SSI Package:
art
Duration:

Description

Verify that intermediate_table PROLOG items are ignored by the command-line handling, and test / fix if necessary.

History

#1 Updated by Christopher Green over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Christopher Green
  • Target version set to 1.18.00
  • Estimated time set to 2.00 h

#2 Updated by Kyle Knoepfel about 5 years ago

  • Project changed from cet-is to art
  • Assignee changed from Christopher Green to Kyle Knoepfel
  • % Done changed from 0 to 100
  • Scope set to Internal
  • SSI Package art added

This issue took longer to implement due to a misunderstanding of what was intended. Specifically, the intent was to verify that for calls such as raw_config.exists(some_key) in the command-line handlers, it would also be verified that some_key was not a prolog item. I implemented this check only for calls to intermediate_table::exists. There were very few other calls to intermediate_table functions for which such a check would be appropriate/necessary.

Implemented with art:dad2855.

#3 Updated by Kyle Knoepfel about 5 years ago

  • Status changed from Assigned to Resolved

#4 Updated by Christopher Green almost 5 years ago

  • Target version changed from 1.18.00 to 1.17.00

#5 Updated by Kyle Knoepfel almost 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF