Project

General

Profile

Bug #860

Double NuMI triggers

Added by Peter Shanahan almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
01/24/2011
Due date:
% Done:

0%

Estimated time:
component:
base
Duration:

Description

Tricia and Minerba reported that every NuMI spill in run 11222 was duplicate. I.e., the same event would appear
twice in the file, but with different trigger number.

This is an odd one. The timestamps are not actually identical. See CRL entry:
http://dbweb1.fnal.gov:8104/nova/SingleEntry.jsp?entryPath=/Entries/2011/01month/24day/16hour/General/Log/Text_2239

copied below for convenience. Also attached is plot of the difference distribution.

Monday, January 24, 2011 17:48:35 CST: General: 2239: Peter Shanahan

Investigating double-NuMI-trigger problem in
run 11222.

Looking at 11222, subrun 2, I find,

1) Only NuMI triggers show this behavior. BNB
and Cosmics, which both exist in this subrun, are
fine.

That would seem to rule out multiple GlobalTrigger or SpillServer processes as the
culprit.

2) Every NuMI trigger in this subrun is
duplicated, i.e., it never failed to happen.

3) It seems that the first event (in the file) of
each pair has the higher trigger number.

4) The time difference between the two triggers
in each pair fall into only the following values:

+/- 24 NOvA clock ticks, less than 10% of the time
(The difference I measure is in nanoseconds, in
this case 375ns)

+/- 28 NOvA clock ticks, the remaining times.
(In nanoseconds, this shows up as +/-437 or +/- 438 nanoseconds)

The distribution of these 4 values is random,
not following any apparent time series.

double_spills_odd_minus_even.png (8.33 KB) double_spills_odd_minus_even.png Peter Shanahan, 01/24/2011 05:57 PM

History

#1 Updated by Peter Shanahan over 8 years ago

  • Status changed from New to Closed

This has not re-occurred since, so closing for now. I don't think the cause was ever discovered.



Also available in: Atom PDF