Project

General

Profile

Idea #7601

HTCondor version requirements

Added by Marco Mambelli over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Category:
Integration with Condor
Target version:
Start date:
01/09/2015
Due date:
% Done:

0%

Estimated time:
Stakeholders:
Duration:

Description

I'm opening this ticket to track possible HTCondor version requirements
Currently the RPM packages (factory/frontend) require condor >=7.8

Known issues:
- there is a known bug where 8.2.2 schedd cannot talk with 8.0.x startd. This is in the release notes, fixed in 8.2.3
The recommendation is to avoid 8.2.2
- the shutdown expression of the glideins works better with >=8.1.6
Still works for lower versions, but the timing is different. This is in the documentation

Marco

History

#1 Updated by Marco Mambelli over 5 years ago

The GANGLIAD, enabled in GWMS 3.2.8 (01_gwms_ganglia.config) is not available in HTCondor 8.0.x
The setup causes the condor master to crash
condor_status -any outputs:

Error: communication error
CEDAR:6001:Failed to connect to <131.225.154.199:9618>

Removing /etc/condor/config.d/01_gwms_ganglia.config solves the problem

To be more precise:
glideinwms-usercollector-3.2.8-1.osg32.el5.noarch has the file /etc/condor/config.d/01_gwms_ganglia.config
This contains DAEMON_LIST = $(DAEMON_LIST), GANGLIAD
This causes a master crash after outputing in the MasterLog:

01/09/15 11:24:23 GANGLIAD is in the DAEMON_LIST parameter, but there is no executable path for it defined in the config files!
01/09/15 11:24:23 ERROR "Must have the path to GANGLIAD defined." at line 1369 in file /builddir/build/BUILD/condor-8.0.6/src/condor_master.V6/masterDaemon.cpp

#2 Updated by Marco Mambelli over 5 years ago

In the smoke tests for 3.2.8 I had a problem with an update form 3.2.7 on fermicloud322 (SL5).
I repeated a test downgrading condor to 8.0.6 ($CondorVersion: 8.0.6 Mar 25 2014 $ $CondorPlatform: X86_64-CentOS_5.10 $).
The test worked after taking case of the gangliad problem (see above).
Different condor versions were used for glideins.

That's probably the problem that affected the previous test but at the time I did not check the MasterLog and investigated the issue.

To summarize:
GWMS 3.2.8 is compatible at least with HTCondor >= 8.0.6 once the gangliad configuration is removed

#3 Updated by Marco Mambelli over 5 years ago

Modified 3.2.8 documentation to highlight the gangliad requirements: git v3/7601, merged to v3_2 and master.

#4 Updated by Parag Mhashilkar over 5 years ago

  • Target version set to v3_2_9

#5 Updated by Marco Mambelli over 5 years ago

Meeting 150126: OK to bump requirement to HTCondor 8.2

#6 Updated by Marco Mambelli over 5 years ago

  • Status changed from New to Feedback
  • Assignee changed from Marco Mambelli to Parag Mhashilkar

I updated the spec file in svn to bump the requirement to 8.2

#7 Updated by Parag Mhashilkar over 5 years ago

  • Status changed from Feedback to Resolved
  • Assignee changed from Parag Mhashilkar to Marco Mambelli

#8 Updated by Parag Mhashilkar about 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF