Project

General

Profile

Bug #7587

csh support

Added by Herbert Greenlee over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
01/06/2015
Due date:
% Done:

100%

Estimated time:
8.00 h
Spent time:
Duration:

Description

At one time, mrb was allegedly made to support csh. Now when you setup mrb, you get the following error:

% setup mrb
CET_PLATINFO: Undefined variable.

The problem is actually in dependent product cetpkgsupport:

% setup cetpkgsupport
CET_PLATINFO: Undefined variable.

Here is some additional ups environment info.

% which ups
/grid/fermiapp/products/larsoft/ups/v5_1_2/Linux64bit+2.6-2.12/bin/ups
% echo $PRODUCTS
/grid/fermiapp/products/uboone:/grid/fermiapp/products/larsoft:/grid/fermiapp/products/common/db
% ups list -aK+ cetpkgsupport
"cetpkgsupport" "v1_02_00" "NULL" "" ""
"cetpkgsupport" "v1_05_02" "NULL" "" ""
"cetpkgsupport" "v1_05_03" "NULL" "" ""
"cetpkgsupport" "v1_05_04" "NULL" "" ""
"cetpkgsupport" "v1_05_05" "NULL" "" ""
"cetpkgsupport" "v1_06_02" "NULL" "" ""
"cetpkgsupport" "v1_07_01" "NULL" "" "current"

History

#1 Updated by Lynn Garren over 5 years ago

  • Project changed from LArSoft to cetpkgsupport
  • Category deleted (Install / build / code mgmt)
  • Status changed from New to Assigned
  • Assignee set to Lynn Garren
  • Estimated time set to 8.00 h

The problem is, as you note, a problem with cetpkgsupport, so I have reassigned it.

#2 Updated by Lynn Garren over 5 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

cetpkgsupport v1_08_02 is now installed on /grid/fermiapp/products/larsoft. This behaves as expected when setup with both bash and tcsh.

#3 Updated by Lynn Garren over 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF