Project

General

Profile

Bug #7564

prints need protection from qualifiers starting with "-"

Added by Gianluca Petrillo almost 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Target version:
-
Start date:
12/22/2014
Due date:
% Done:

100%

Estimated time:
Duration:

Description

I have gotten a strange error, that I am not even sure I can systematically reproduce.

$ mrb install -j4
/uboone/app/users/petrillo/LArSoft/develop/e6_prof/build_slf6.x86_64
calling buildtool -I /uboone/app/users/petrillo/LArSoft/develop/e6_prof/localProducts_larsoft_v03_04_06_e6_prof -i -j4
/grid/fermiapp/products/larsoft/cetbuildtools/v4_03_03/bin/buildtool: line 494: printf: -n: invalid option
printf: usage: printf [-v var] format [arguments]
ERROR: Qualifier has changed from "-nq-:prof" to "e6:prof": need clean build.

I am reporting this because in buildtool printf calls should be protected from arguments that can start with a dash.
At line 494 of cetbuildtools v4_03_03,
printf "$1" | tr ':' '\n' | sort | tr '\n' ':' | sed -e 's/:$//'
should read
printf -- "$1" | tr ':' '\n' | sort | tr '\n' ':' | sed -e 's/:$//'

Note: this issue is not about the mrb problem that triggers that output, which is probably a temporary glitch in my shell.

History

#1 Updated by Lynn Garren almost 5 years ago

  • Status changed from New to Feedback

We believe that if you try again with the latest mrb and cetbuildtools you will not have this problem, since nq should not be passed to buildtool.

Additionally, a fix has been committed to buildtool which will be available in an upcoming release of cetbuildtools.

#2 Updated by Lynn Garren over 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

#3 Updated by Lynn Garren over 3 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF