Project

General

Profile

Bug #7351

root gui bug in v1_12_00

Added by Herbert Greenlee almost 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Third Party
Target version:
-
Start date:
11/19/2014
Due date:
% Done:

0%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
MicroBooNE
SSI Package:
Duration:

Description

Larsoft recently updated from art v1_10_00b to v1_12_00 (larsoft v02_06_02 to v03_00_00). This version update also entailed updates of several dependent products, including root v5_34_18d to v5_34_21 and gcc v4_8_2 to v4_9_1 (c++11 to c++14). Since this update, the larsoft event display ortho3D view is partially broken. I traced the problem to certain mouse events (specifically kButton1Motion events) being sent to the wrong TPad (i.e. not the pad that the mouse is located in).

This problem seems like an issue with the underlying root (larsoft event display code did not change between these versions). Problem could be either the compiler change or the root version change.

Any help with this problem will be appreciated.

History

#1 Updated by Lynn Garren almost 5 years ago

  • Status changed from New to Feedback

I've installed root v5_34_23 in /grid/fermiapp/products/larsoft. Please test. There is a good chance that this will solve the problem.

#2 Updated by Herbert Greenlee almost 5 years ago

Just setting up the new root version crashes. I don't think I can test without a whole new version of art.

#3 Updated by Lynn Garren almost 5 years ago

I've installed the nu-v1_07_00 bundle, which includes nutools v1_07_00 and art v1_12_04, as well as genie v2_8_0m and pandora v00_17a.

#4 Updated by Kyle Knoepfel over 4 years ago

  • Target version set to 521

#5 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Feedback to Resolved

#6 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Resolved to Closed

#7 Updated by Kyle Knoepfel almost 2 years ago

  • Target version deleted (521)


Also available in: Atom PDF