Project

General

Profile

Bug #7346

jobsub_submit with no args errors out when JOBSUB_GROUP is set

Added by Parag Mhashilkar over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Parag Mhashilkar
Category:
JobSub Client
Target version:
Start date:
11/19/2014
Due date:
% Done:

100%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

Hi,

Setting JOBSUB_GROUP causes the problem. If setting that variable is omitted, then I get the desired behavior.

From a fresh login:

<tice@seaquestgpvm01> ~ [1000] $ source /grid/fermiapp/products/common/etc/setups.sh

<tice@seaquestgpvm01> ~ [1001] $ export JOBSUB_GROUP=seaquest

<tice@seaquestgpvm01> ~ [1002] $ setup jobsub_client

<tice@seaquestgpvm01> ~ [1003] $ jobsub_submit

JobSubClient instance has no attribute 'serverArgs_b64en'

Traceback (most recent call last):

File "/grid/fermiapp/products/common/db/../prd/jobsub_client/v1_0_3/NULL/jobsub_submit", line 222, in main

js_client.submit()

File "/grid/fermiapp/products/common/prd/jobsub_client/v1_0_3/NULL/jobsubClient.py", line 278, in submit

('jobsub_args_base64', self.serverArgs_b64en),

AttributeError: JobSubClient instance has no attribute 'serverArgs_b64en'

History

#1 Updated by Parag Mhashilkar over 4 years ago

  • Category set to JobSub Client
  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fix is in master

#2 Updated by Parag Mhashilkar over 4 years ago

  • Target version changed from v1.1 to v1.0.4

#3 Updated by Parag Mhashilkar over 4 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF