Project

General

Profile

Feature #7322

Change in fastCloning default value

Added by Wesley Ketchum almost 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
11/13/2014
Due date:
% Done:

100%

Estimated time:
Scope:
Internal
Experiment:
MicroBooNE
SSI Package:
art
Duration:

Description

We've come across this many times on microboone: if we change a data product and attempt to read in old data, output will fail with a hard-to-diagnose error due to the fast cloning being turned on by default. While I understand that it's more efficient to leave it on (when appropriate), I really think it would be better to have it "false" by default, and have people turn it to true if they know what they are doing will be ok with it turned on. That should lead to fewer head-scratching errors.

So ... can I request a change in the default for the root output fast cloning to be false?

History

#1 Updated by Christopher Green almost 5 years ago

  • Status changed from New to Feedback
  • SSI Package art added
  • SSI Package deleted ()

Changing this default value could be problematic here. I would like to discuss this at an upcoming stakeholders meeting.

#2 Updated by Kyle Knoepfel over 4 years ago

  • Target version set to 521

#3 Updated by Kyle Knoepfel about 3 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

This issue was resolved in art 2.03.00.

#4 Updated by Kyle Knoepfel almost 2 years ago

  • Target version deleted (521)


Also available in: Atom PDF