Project

General

Profile

Bug #7232

Build error for dictionaries in art v1_12_02 (gcc 4_9_1)

Added by Adam Lyon over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
I/O
Target version:
Start date:
10/28/2014
Due date:
% Done:

100%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

I get the following error when trying to build a dictionary (the important part is at the bottom)...

[  9%] Building CXX object gm2artexamples/DataObjects/CMakeFiles/gm2artexamples_DataObjects_dict.dir/gm2artexamples_DataObjects_dict.cpp.o
In file included from /Users/lyon/Development/g-2/products_v1_12_02/d13/external/art/v1_12_02/include/art/Persistency/Common/Wrapper.h:126:0,
                 from /Users/lyon/Development/g-2/try3/srcs/gm2artexamples/DataObjects/classes.h:19,
                 from /Users/lyon/Development/g-2/try3/build_d13.x86_64/gm2artexamples/DataObjects/gm2artexamples_DataObjects_dict.cpp:29:
/Users/lyon/Development/g-2/products_v1_12_02/d13/external/art/v1_12_02/include/art/Persistency/Common/setPtr.h: In function ‘void art::setPtr(const cet::map_vector<T>&, const std::type_info&, long unsigned int, const void*&)’:
/Users/lyon/Development/g-2/products_v1_12_02/d13/external/art/v1_12_02/include/art/Persistency/Common/setPtr.h:47:30: error: typedef ‘product_type’ locally defined but not used [-Werror=unused-local-typedefs]
   typedef cet::map_vector<T> product_type;
                              ^
cc1plus: all warnings being treated as errors

Associated revisions

History

#1 Updated by Christopher Green over 4 years ago

  • Category set to I/O
  • Status changed from New to Feedback
  • Assignee set to Christopher Green
  • Target version set to 1.12.03
  • SSI Package art added
  • SSI Package deleted ()

This is a real error that should never have been seen because the problem is in a function that should not have been instantiated by the compiler.

Please submit your _dict.cpp as an attachment for analysis. In the meantime, the underlying problem has been fixed with commit commit:27480da.

#2 Updated by Christopher Green over 4 years ago

Adam, could I ask you to provide the requested _dict.cpp for us to examine?

#3 Updated by Christopher Green over 4 years ago

  • Description updated (diff)

#4 Updated by Christopher Green over 4 years ago

  • Target version changed from 1.12.03 to 1.12.04

#5 Updated by Christopher Green about 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Resolved due to lack of feedback.

#6 Updated by Christopher Green about 4 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF