Project

General

Profile

Feature #7110

Removal of MF_ExtModules library

Added by Ben Morgan almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Low
Assignee:
Target version:
Start date:
10/06/2014
Due date:
% Done:

100%

Estimated time:
0.25 h
Spent time:
Duration:

Description

MessageFacility always builds the MF_ExtModules library, which is always dynamically loaded in MessageLoggerScribe::configure_errorlog(). However, the MF_ExtModules library only contains one empty extension class MFExtensions, so loading this library seems defunct given the (apparent) lack of functionality it provides.

Could this library be removed, or the MFExtensions class moved elsewhere if in MessageFacility it is still required as an interface (I'm happy to supply patches in either case)? Otherwise, could documentation on writing and loading extensions (presumably via a fhicl file)
be provided please?

History

#1 Updated by Christopher Green almost 5 years ago

  • Tracker changed from Support to Feature
  • Subject changed from Use of MF_ExtModules library to Removal of MF_ExtModules library
  • Status changed from New to Accepted
  • Priority changed from Normal to Low

This is vestigial code that was used in a fork. We have short-medium-term plans for a more flexible destination plugin system using the PluginFactory in more recent versions of cetlib, at which time this code will be replaced. Since it is not currently used however, we would be happy to take a patch for its removal.

#2 Updated by Ben Morgan almost 5 years ago

Patch against current master branch (with Kyle's latest fixes) attached. This simply removes the dynamic loading of MF_ExtMod and all associated files/buildscripts for the library. There may be some remaining to connection to Extensions via EldestinationFactory, but build appears o.k. as does usage in art.

#3 Updated by Kyle Knoepfel almost 5 years ago

  • Assignee set to Kyle Knoepfel

#4 Updated by Kyle Knoepfel almost 5 years ago

  • Estimated time set to 0.25 h

Patch has been implemented and pushed to repository. Appropriate compile- and run-time behavior confirmed. Thanks for the patch.

#5 Updated by Kyle Knoepfel almost 5 years ago

  • % Done changed from 0 to 100

#6 Updated by Kyle Knoepfel almost 5 years ago

  • Status changed from Accepted to Resolved

#7 Updated by Christopher Green over 4 years ago

  • Target version set to 1.12.04

#8 Updated by Christopher Green over 4 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF