Project

General

Profile

Bug #7053

Bug #6394: Verify that association query objects are created outside tight loops

FindManyP() usage in EventDisplay library

Added by Gianluca Petrillo over 6 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Event Display
Target version:
-
Start date:
09/22/2014
Due date:
% Done:

0%

Estimated time:
1.00 h
Occurs In:
Experiment:
LArSoft
Co-Assignees:
Duration:

Description

The RecoBaseDrawer component of the EventDisplay library uses FindMany family extensively.

lareventdisplay/EventDisplay/RecoBaseDrawer.cxx

I am not completely sure here, but it seems that in RecoBaseDrawer::Event3D(), FindManyP in the inner loop might be brought one loop out.

Contact person: Brian Rebel ().

History

#1 Updated by Brian Rebel over 6 years ago

  • Status changed from Assigned to Rejected

I don't believe that the FindManyP constructors for the shower to vertex and track to vertex associations can be moved. The issue is that we need the collection of Vertex objects from the event before we can map to the tracks and showers.

One possible solution, that would require some work through several packages would be to ensure that event to track and event to shower associations were made every time an event is made. Then the inner loop over vertex objects could be removed and one could draw the tracks and showers directly from the events.

Also available in: Atom PDF