Project

General

Profile

Support #7022

GDB errors in art v1_11_02 suite

Added by Kanika Sachdev about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Category:
User Code
Target version:
-
Start date:
09/16/2014
Due date:
% Done:

100%

Estimated time:
Spent time:
Scope:
Internal
Experiment:
NOvA
SSI Package:
Duration:

Description

Hi,

Since we updated to art v1_11_02 suite, gcc 4.9.1 with -std=c++1y, if we run gdb on any nova jobs, we get the following error messages:

Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /nusoft/app/externals/tbb/v4_2_5/Linux64bit+2.6-2.5-e6-prof/lib/libtbb.so.2]
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /nusoft/app/externals/gcc/v4_9_1/Linux64bit+2.6-2.5/lib64/libstdc++.so.6]
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /nusoft/app/externals/gcc/v4_9_1/Linux64bit+2.6-2.5/lib64/libgcc_s.so.1]
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /nusoft/app/externals/pythia/v6_4_28b/Linux64bit+2.6-2.5-gcc491-prof/lib/libPythia6.so]
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /nusoft/app/externals/gcc/v4_9_1/Linux64bit+2.6-2.5/lib64/libgfortran.so.3]
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /nusoft/app/externals/gcc/v4_9_1/Linux64bit+2.6-2.5/lib64/libquadmath.so.0]
Error while reading shared library symbols:
Dwarf Error: wrong version in compilation unit header (is 4, should be 2) [in module /nusoft/app/externals/xerces_c/v3_1_1b/Linux64bit+2.6-2.5-e6-prof/lib/libxerces-c-3.1.so]

etc..

These messages just flood the screen but if you don't abort in fear and let it get past the first step of loading the geometry, I've got some use out of gdb. So it doesn't seem to be completely broken, but I don't know how much to trust it's debugging, given those errors.

What is causing these errors? Can we do something on our end to make them stop?

Thanks,
Kanika

History

#1 Updated by Christopher Backhouse about 6 years ago

I've had programs run under gdb, but when I try to do anything after hitting a breakpoint I get similar dwarf-version-related errors and can't do much of any use.

#2 Updated by Christopher Green about 6 years ago

  • Tracker changed from Bug to Support
  • Category set to User Code
  • Status changed from New to Feedback
  • Assignee set to Christopher Green

Please tell us the full path to the gdb you are using, and the result of gdb --version.

#3 Updated by Kanika Sachdev about 6 years ago

Oh I see what the problem is:

which gdb

/usr/bin/gdb

gdb --version

GNU gdb Fedora (6.8-37.el5)

We should be setting up gdb v7_8 ups product in our normal setup.

#4 Updated by Christopher Green about 6 years ago

Please let us know if that solves your problem.

#5 Updated by Kanika Sachdev about 6 years ago

It solves mine.

Thanks,
Kanika

#6 Updated by Christopher Green about 6 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

#7 Updated by Christopher Green about 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF