Project

General

Profile

Bug #6887

-fix_rrd should be in the upgrade rather than reconfig option

Added by Parag Mhashilkar over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
08/28/2014
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:
Duration:

Description

We should make sure that this is ok with the rpms as well.

History

#1 Updated by Parag Mhashilkar over 4 years ago

  • Assignee set to Parag Mhashilkar
  • Target version set to v3_3

#2 Updated by Parag Mhashilkar about 4 years ago

  • Assignee changed from Parag Mhashilkar to HyunWoo Kim

#3 Updated by Parag Mhashilkar over 3 years ago

  • Priority changed from Normal to Low

#4 Updated by Parag Mhashilkar almost 3 years ago

  • Target version changed from v3_3 to v3_3_1

#5 Updated by Parag Mhashilkar over 2 years ago

  • Target version changed from v3_3_1 to v3_3_2

#6 Updated by Parag Mhashilkar over 2 years ago

  • Target version changed from v3_3_2 to v3_3_3

#7 Updated by HyunWoo Kim over 2 years ago

I reviewed /etc/init.d/gwms-frontend and /etc/init.d/gwms-factory in order to find out
how currently we are using fix_rrd option in reconfig() and upgrade()

1. frontend-reconfig
- fix_rrd is optinal for both RPM-install and non-RPM-install
- Q) shall I disable this? I think I can because it is currently optional anyway.
- A) no, don't need to disable it. Leaving it as it is (optional) will do no harm
2. factory-reconfig
- fix_rrd is optinal for both RPM-install and non-RPM-install
- Q) shall I disable this? I think I can because it is currently optional anyway.
- A) no, don't need to disable it. Leaving it as it is (optional) will do no harm

3. frontend-upgrade
- fix_rrd is always used for both RPM-install and non-RPM-install
- Q) shall I make this optional?
- A) no, the answer is, fix_rrd should be always used..

4. factory-upgrade
- currently fix_rrd is used as option for non-RPM-install, and not used at al for RPM-install
- I confirmed that using fix_rrd option for RPM-install works too.
- Q) shall I make this used always for both installs just like current frontend-upgrade?
- A) yes, this is what should be done.

- Q) or shall I make this optional for for both installs?
- A) no the answer is, fix_rrd should be always used..
Answering these questions will indicate a way to resolve this ticket..

The difference between reconfig and upgrade:
reconfig is used whenever configuration changes are made, once the service (frontend or factory) is installed and started.
upgrade is used when the service is reinstalled (new rpm)

Note that a change that results from this ticket will not affect 14194(SL7 init script) because the new sl7 init scripts in 14194 only use default option to reconfig.
All other uses of reconfig and upgrade should use /usr/sbin/gwms-{frontend,factory} directly.

#8 Updated by HyunWoo Kim about 2 years ago

I will make fix_rrd a default feature of upgrade in both rpm and tarball installs.
I then need to actually test using fix_rrd option updates the rrd structure if I actually make changes to the rrd.

#9 Updated by HyunWoo Kim about 2 years ago

  • Status changed from New to Feedback
  • Assignee changed from HyunWoo Kim to Marco Mambelli

Branched off from the master branch (instead of branch_v3_2 because this is targeted at v3_3_3).
Mofified creation/templates/factory_initd_startup_template and creation/templates/factory_initd_startup_template_sl7
to use -fix_rrd option always in the upgrade() function for both rpm-install and tarball-install
Assigning to Marco for feedback

#10 Updated by Marco Mambelli almost 2 years ago

  • Assignee changed from Marco Mambelli to HyunWoo Kim
  • Target version changed from v3_3_3 to v3_2_20

moved to the production series, see email

#11 Updated by HyunWoo Kim almost 2 years ago

  • Status changed from Feedback to Resolved

I created a new branch v3/6887_2 off branch_v3_2
and moved all the changes from v3/6887(which was off the master branch) to this new branch
and then I merged v3/6887_2 into branch_v3_2 and pushed branch_v3_2 to origin/branch_v3_2
This ticket is resolved now..

#12 Updated by HyunWoo Kim over 1 year ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF