Project

General

Profile

Bug #6801

Possible failure of config_dumper to dump services configuration.

Added by Christopher Green about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
High
Category:
Metadata
Target version:
Start date:
08/14/2014
Due date:
% Done:

100%

Estimated time:
2.00 h
Spent time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

Tom Junk reports that config_dumper in 1.09.04 still fails to dump the service configuration.


Related issues

Related to art - Feature #3639: Recovering Parameter Sets used to Configure ServicesClosed05/01/2013

Related to art - Necessary Maintenance #1014: some parameter sets in the ServicesManager do not have service_type definedClosed02/25/201109/30/2013

History

#1 Updated by Christopher Green about 6 years ago

  • Status changed from Assigned to Feedback

Tom, please let us know the command you used so we can reproduce the problem with your data file. If you can do this quickly, we have a chance of getting any necessary fix into version:Sol.

As an aside, dumping the service configuration requires an option to be specified: see config_dumper -h for details.

#2 Updated by Christopher Green about 6 years ago

  • Status changed from Feedback to Assigned
  • Estimated time set to 2.00 h

From Tom:

The command with full path names. Executed on lbnegpvm05:

My setup:

source /grid/fermiapp/lbne/software/setup_lbne.sh
cd /lbne/app/users/trj/mt2
setup larsoft v02_04_00 -q e5:prof
source /lbne/app/users/trj/mt2/localProducts_larsoft_v02_04_00_e5_prof/setup
cd build_slf6.x86_64/
mrbsetenv

My command:

config_dumper single35t_gen.root

Which gives the same old output as before (no services)

I also tried:

config_dumper -S single35t_gen.root

but got only this as output:

TrivialFileTransfer: {
}

TrivialFileDelivery: {
}

LBNEGeometryHelper: {
}

Same with

config_dumper —services singel35t_gen.root

I am expecting one or more lines that specify the gdml file used to simulate the event. And lots of other services config parameters.

Tom

This problem has been duplicated in 1.10.00b.

As a workaround, please use config_dumper -P to see the information you need.

#3 Updated by Christopher Green about 6 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

This problem was due to the fact that parameter set labels are not attached to the parameter sets themselves, and the service_type generated parameter was not added to the set until after the set had been saved in the registry.

The service_type parameter is now added to service configuration sets at configuratoin post-processing time, analogous to module_type for module parameter sets.

Fixed with 1542c7a.

#4 Updated by Christopher Green about 6 years ago

It should be noted that this is a fix for files generated going forward. For existing files, the previously mentioned workaround is the only available measure.

#5 Updated by Christopher Green about 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF