Project

General

Profile

Bug #6739

Lacking Permissions

Added by Steven Boi almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
08/03/2014
Due date:
% Done:

100%

Estimated time:
Duration:

Description

Hello,

I logged into the mu2egpvm05.

I am unable to make a directory in my home directory, so I went to where I keep my other files /grid/data/mu2e/personal/kc9qin/ and made a directory there. I was able to gather all the files and make, but in following the instructions, make test returns this error:

<mu2egpvm05.fnal.gov> make test
./dataGen > testlog_dataGen
/bin/sh: ./dataGen: Permission denied
make: *** [dataGen.test] Error 126

I then attempted to run by hand both ./dataGen >& dataGen.log and ./dataRead >& dataRead.log, which appeared to worked. But trying to perform diff dataGen.log dataRead.log gives this:

<mu2egpvm05.fnal.gov> diff dataGen.log dataRead.log
1c1
< -bash: ./dataGen: Permission denied
---
> -bash: ./dataRead: Permission denied

History

#1 Updated by Rob Kutschke almost 5 years ago

Hi Steven,

Please let me know if you get this by replying to this ticket.
About making a subdirectory in your home directory.  Two questions:
1) Have you successfully done it before and it just failed this time?
2) Have you been logged to mu2egpvm05 for more than a day?
The solution is to put your files on  /mu2e/app/users

You should be able to make a directory for yourself there - name it after your kerberos principal.

The reason that you cannot make a file on /grid/data/mu2e is the following.  Fermilab policy is that if a disk a writeable from a grid node it must be mounted noexec on the interactive nodes.  This is a security feature to stop rogue grid jobs from writing code to disks from which it can be run on interactive nodes.  See:
http://mu2e.fnal.gov/public/hep/computing/hardwareResources.shtml#BlueArc

Let me know if it works.

Rob

#2 Updated by Steven Boi almost 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Hi Rob,

I received your response.

For making a sub-directory in my home directory:
1) Today was the first time attempting to make one. There weren't any permissions to change to the various sub-directories either.
2) This was my first login to mu2egpvm05; login duration on the scale of a few hours.

I placed the files into /mu2e/app/users/kc9qin and it worked.

Thank you,
Steve



Also available in: Atom PDF