Project

General

Profile

Bug #6715

libwda linking problem

Added by Lynn Garren about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/31/2014
Due date:
% Done:

0%

Estimated time:
Spent time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

Kanika reported a problem linking against libwda v2_13_0 because it was trying to find libwda.so.2. This library was built, but not installed by the libwda Makefile.

History

#1 Updated by Lynn Garren about 6 years ago

  • Status changed from New to Resolved

There is a new release of the ifdh suite. It now contains:
libwda v2_13_0a
ifdhc v1_4_3
ifbeam v1_4_3a
nucondb v1_4_3a
ifdh_art v1_4_3a

The libwda shared libraries were not installed properly. That is now
fixed. Since the code remains the same, this a "patch" release. This
drove new patch releases of ifbeam and nucondb. ifdhc does not depend
on libwda and is unchanged.

Also, you will note the return to a more sensible version for ifdh_art.
We have added a new qualifier: s1, s2, or s3. The "s" is short for
"version set". You will find them listed as secondary qualifiers at
https://cdcvs.fnal.gov/redmine/projects/cet-is-public/wiki/AboutQualifiers

s1 -> art v1_09_03
s2 -> art v1_09_04
s3 -> art v1_10_00b

Also note that ifdh_art is now built with the brand new cetbuildtools
v4_00_00, which supports this features.

#2 Updated by Christopher Green about 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF