Project

General

Profile

Bug #6683

unnecessary network requests

Added by Andrei Gaponenko over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Low
Category:
Infrastructure
Target version:
-
Start date:
07/25/2014
Due date:
% Done:

0%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

Hello,

My short test runs of mu2e art became very slow this evening. I would
type "mu2e -c my.fcl localfile.root", hit "Enter", and nothing would
happen for a while.

stracing the job showed that it tried to talk to the network and timed
out, then tried again... (The last few lines of the transcript below.)

Why does a self-contained local job tries to access the network?
(There was a network outage tonight.)

Andrei

....
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=163106, ...}) = 0
mmap(NULL, 163106, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7f4990d3c000
close(3)                                = 0
open("/lib64/libnss_dns.so.2", O_RDONLY) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\0\20\0\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=27424, ...}) = 0
mmap(NULL, 2117880, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f4990b36000
mprotect(0x7f4990b3b000, 2093056, PROT_NONE) = 0
mmap(0x7f4990d3a000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x4000) = 0x7f4990d3a000
close(3)                                = 0
mprotect(0x7f4990d3a000, 4096, PROT_READ) = 0
munmap(0x7f4990d3c000, 163106)          = 0
socket(PF_INET, SOCK_DGRAM|SOCK_NONBLOCK, IPPROTO_IP) = 3
connect(3, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("131.225.0.254")}, 16) = 0
poll([{fd=3, events=POLLOUT}], 1, 0)    = 1 ([{fd=3, revents=POLLOUT}])
sendto(3, "M\351\1\0\0\1\0\0\0\0\0\0\vlocaldomain\4dhcp\4fn"..., 43, MSG_NOSIGNAL, NULL, 0) = 43
poll([{fd=3, events=POLLIN}], 1, 5000)  = 0 (Timeout)
poll([{fd=3, events=POLLOUT}], 1, 0)    = 1 ([{fd=3, revents=POLLOUT}])
sendto(3, "M\351\1\0\0\1\0\0\0\0\0\0\vlocaldomain\4dhcp\4fn"..., 43, MSG_NOSIGNAL, NULL, 0) = 43

History

#1 Updated by Rob Kutschke over 5 years ago

Is this on your laptop? On mu2egpvm* or detsim? If the latter can you tell if the network traffic is related to network mounted disks?

#2 Updated by Christopher Green over 5 years ago

  • Category set to Infrastructure
  • Status changed from New to Feedback
  • Assignee set to Christopher Green
  • SSI Package art added
  • SSI Package deleted ()

If you can, please run this in a debugger with a breakpoint set on socket() and let us have the resulting stack trace.

#3 Updated by Andrei Gaponenko over 5 years ago

Here is the stack trace:

Breakpoint 1, 0x0000003d054e9c10 in socket () from /lib64/libc.so.6
(gdb) where
#0  0x0000003d054e9c10 in socket () from /lib64/libc.so.6
#1  0x0000003d0552355f in open_socket () from /lib64/libc.so.6
#2  0x0000003d05523a67 in get_mapping () from /lib64/libc.so.6
#3  0x0000003d05523e4c in __nscd_get_map_ref () from /lib64/libc.so.6
#4  0x0000003d055206b1 in nscd_getpw_r () from /lib64/libc.so.6
#5  0x0000003d05520a68 in __nscd_getpwuid_r () from /lib64/libc.so.6
#6  0x0000003d054ac119 in getpwuid_r@@GLIBC_2.2.5 () from /lib64/libc.so.6
#7  0x0000003d054ab95f in getpwuid () from /lib64/libc.so.6
#8  0x00007ffff4e9de9c in TUnixSystem::UnixHomedirectory(char const*) () from /data/fermiapp/sl6/artexternals/root/v5_34_09b/Linux64bit+2.6-2.12-mu2e-e4-prof/lib/libCore.so
#9  0x00007ffff4e0b003 in TROOT::InitSystem() () from /data/fermiapp/sl6/artexternals/root/v5_34_09b/Linux64bit+2.6-2.12-mu2e-e4-prof/lib/libCore.so
#10 0x00007ffff4e0ceef in TROOT::TROOT(char const*, char const*, void (**)()) () from /data/fermiapp/sl6/artexternals/root/v5_34_09b/Linux64bit+2.6-2.12-mu2e-e4-prof/lib/libCore.so
#11 0x00007ffff4e0e40c in ROOT::GetROOT() () from /data/fermiapp/sl6/artexternals/root/v5_34_09b/Linux64bit+2.6-2.12-mu2e-e4-prof/lib/libCore.so
#12 0x00007ffff4e0ef20 in _GLOBAL__sub_I_TROOT.cxx () from /data/fermiapp/sl6/artexternals/root/v5_34_09b/Linux64bit+2.6-2.12-mu2e-e4-prof/lib/libCore.so
#13 0x00007ffff521ad86 in __do_global_ctors_aux () from /data/fermiapp/sl6/artexternals/root/v5_34_09b/Linux64bit+2.6-2.12-mu2e-e4-prof/lib/libCore.so
#14 0x00007ffff4db2593 in _init () from /data/fermiapp/sl6/artexternals/root/v5_34_09b/Linux64bit+2.6-2.12-mu2e-e4-prof/lib/libCore.so
#15 0x00007fffee9d1000 in ?? ()
#16 0x0000003d04c0e555 in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2
#17 0x0000003d04c00b3a in _dl_start_user () from /lib64/ld-linux-x86-64.so.2
#18 0x0000000000000001 in ?? ()
#19 0x00007fffffff9e10 in ?? ()
#20 0x0000000000000000 in ?? ()

#4 Updated by Christopher Green over 5 years ago

  • Status changed from Feedback to Rejected

Based on our discussion a couple of weeks ago, I believe that ROOT is obtaining your home directory from the system since it can't guarantee that HONE is set in e.g. grid environments. This, on certain systems, might necessitate network connection. I am rejecting this as not a bug in art. If you wish to file a bug against ROT, please do so at https://sft.its.cern.ch/jira/browse/ROOT.



Also available in: Atom PDF