Project

General

Profile

Bug #6619

need to require later version of boost

Added by Eric Stern over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Start date:
07/13/2014
Due date:
% Done:

0%

Estimated time:
Duration:

Description

On CentOS 6.5 (and presumably SLF 6.5) synergia fails to build with a system boost 1.41 because boost:math::constants::two_pi is not defined. Either we need to require a later boost or fix the code.

History

#1 Updated by Eric Stern over 5 years ago

  • Status changed from New to Resolved

Fixed with b0cd81c35bd2867e7b377a4437e2a82e26b3a201 Changed the minimum required version to boost 1.48 which has the two_pi constant defined. The boost available on a SL6 or CentOS6 system is 1.41 which is insufficient for Synergia, so requiring 1.48 will force a newer boost (current 1.54) to be built on these systems. Ubuntu 12.04 has boost 1.48 available although it is not the default.

#2 Updated by Eric Stern over 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF