Project

General

Profile

Bug #6571

jobsub_client clobbers python version

Added by Herbert Greenlee about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/27/2014
Due date:
07/30/2014
% Done:

100%

Estimated time:
Spent time:
First Occurred:
Occurs In:
Stakeholders:
Duration: 34

Description

Larsoft sets up a ups version of python as part of its environment (python 2.7.6). Setting up jobsub_client unsets this python and reverts to the system python (/usr/bin/python, version 2.6.6, on uboonegpvmXX). This system python does not work for microboone/larsoft.

Jobsub_client should not insist on a particular version of python.

History

#1 Updated by Parag Mhashilkar about 5 years ago

  • Assignee set to Dennis Box

#2 Updated by Parag Mhashilkar about 5 years ago

  • Target version set to v0.4

#3 Updated by Dennis Box about 5 years ago

Hi Herb,
How do I set up larsoft, and is setting it up and setting up jobsub_client sufficient to reproduce this problem?
When I setup jobsub_client on uboonegpvm* I start with the system python 2.4 in /usr/bin/python, and end up with python 2.7 which is needed for pycurl.
Thanks
Dennis

#4 Updated by Dennis Box about 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

This issue took a surprising amount of time and ultimately expert advice from UPS/UPD gurus. If() Then() Else() in table files lies about order of execution if a SetupRequired() or SetupOptional() appears any where in the file.

#5 Updated by Parag Mhashilkar about 5 years ago

  • Status changed from Resolved to Closed

#6 Updated by Parag Mhashilkar about 5 years ago

  • Due date set to 07/30/2014


Also available in: Atom PDF