Project

General

Profile

Feature #6566

Option to merge output and error streams

Added by Christopher Backhouse over 5 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Start date:
06/27/2014
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Brainstorming desired features, we can discuss them all and decide relative priorities in a meeting

Option to merge output and error streams:

Separating .out and .err loses context of how the messages were interwoven. It's part of the cause of us taking several days to track down a user problem this week.

I would definitely use an option (-oe?) to merge the output and error streams together.

I think implementation is as simple as "exec 2>&1" at the top of art_sam_wrap

You'll still get an empty .err back, but fixing that requires escalating this into jobsub/condor

History

#1 Updated by Alexander Himmel about 3 years ago

  • Status changed from New to Rejected


Also available in: Atom PDF