Project

General

Profile

Bug #6486

No complaint when you don't register a module

Added by Jonathan Asaadi over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
User Code
Target version:
-
Start date:
06/17/2014
Due date:
% Done:

0%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
MicroBooNE
SSI Package:
art
Duration:

Description

So I found a bug where if you make a module and don't include the line DEFINE_ART_MODULE(ModuleName) the code will compile and run without complaint. However, it will simply pick up the wrong library (whichever library previously was being compiled) and just move on.

Only thanks to some help from Kazu and a criptic message from LArSoft at run time identifying that my module was running under the wrong flag was I able to find my error.

I think having a complaint from a producer if this line isn't there might be a good idea

History

#1 Updated by Lynn Garren over 5 years ago

  • Project changed from LArSoft to art

Reassigned to art. The problem is found in art v1_09_03.

#2 Updated by Christopher Green over 5 years ago

  • Category set to User Code
  • Status changed from New to Feedback
  • Assignee set to Christopher Green
  • Scope set to Internal
  • Experiment MicroBooNE added
  • Experiment deleted (-)
  • SSI Package art added
  • SSI Package deleted ()

I'm afraid we're having trouble gleaning enough information from your report to identify the exact problem here. Could we have you visit (or, if you are not at FNAL, talk to us by 'phone) us so we can have a better idea of exactly what happened?

#3 Updated by Kyle Knoepfel almost 5 years ago

  • Target version set to 521

#4 Updated by Kyle Knoepfel over 3 years ago

  • Status changed from Feedback to Closed

Closed due to lack of feedback.

#5 Updated by Kyle Knoepfel over 2 years ago

  • Target version deleted (521)


Also available in: Atom PDF