Project

General

Profile

Bug #6422

ValidHandle lacks functionality

Added by Andrei Gaponenko over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Category:
Navigation
Target version:
Start date:
06/07/2014
Due date:
% Done:

0%

Estimated time:
2.00 h
Spent time:
Occurs In:
Scope:
Internal
Experiment:
Mu2e
SSI Package:
art
Duration:

Description

I get the compilation error below when using a ValidHandle with
FindOne:

auto ih = event.getValidHandle<TrackSummaryCollection>(trackInput_);

art::FindOne<art::Ptr<SimParticle>, mu2e::TrackSummaryMatchInfo>
   f1(ih, event, truthMapInput_);

Using a Handle instead of ValidHandle allows the code to compile.

Andrei

/data/fermiapp/sl6/artexternals/art/v1_08_09/include/art/Framework/Core/FindOne.h: In instantiation of 'art::FindOne<ProdB, DATA>::FindOne(const PtrProdAColl&, const art::Event&, const art::InputTag&) [with PtrProdAColl = art::ValidHandle<std::vector<mu2e::TrackSummary> >; ProdB = art::Ptr<mu2e::SimParticle>; Data = mu2e::TrackSummaryMatchInfo]':
Analyses/src/TrackSummaryAnalyzer_module.cc:292:39:   required from here
/data/fermiapp/sl6/artexternals/art/v1_08_09/include/art/Framework/Core/FindOne.h:472:57: error: no type named 'value_type' in 'class art::ValidHandle<std::vector<mu2e::TrackSummary> >'
   typedef typename PtrProdAColl::value_type::value_type ProdA;
                                                         ^
/data/fermiapp/sl6/artexternals/art/v1_08_09/include/art/Framework/Core/FindOne.h:473:53: error: no type named 'value_type' in 'class art::ValidHandle<std::vector<mu2e::TrackSummary> >'
   detail::IPRHelper<ProdA, ProdB, Data, dataColl_t> finder(e, tag);
                                                     ^
/data/fermiapp/sl6/artexternals/art/v1_08_09/include/art/Framework/Core/FindOne.h:473:53: error: no type named 'value_type' in 'class art::ValidHandle<std::vector<mu2e::TrackSummary> >'

History

#1 Updated by Christopher Green over 5 years ago

  • Category set to Navigation
  • Status changed from New to Accepted
  • Target version set to 1.10.00
  • Estimated time set to 2.00 h
  • Experiment Mu2e added
  • Experiment deleted (-)
  • SSI Package art added
  • SSI Package deleted ()

This is an unintentional omission from the interface of Validhandle, and will be fixed.

#2 Updated by Christopher Green over 5 years ago

  • Status changed from Accepted to Feedback
  • Assignee set to Christopher Green

Can you confirm which version of art you were using when you encountered this problem? We have a test in the current version of art (1.09.03) which would seem to preclude at first glance the problem you see. The feature has been in art since 1.08.10 and was added with 258c74f4.

#3 Updated by Andrei Gaponenko over 5 years ago

I am using art v1_08_09, which just missed the fix.
Andrei

#4 Updated by Christopher Green over 5 years ago

  • Status changed from Feedback to Rejected

Not a bug: missing feature was added in 1.08.10.



Also available in: Atom PDF