Project

General

Profile

Bug #6287

Debugging problems with gdb from gcc v4_8_2

Added by Gianluca Petrillo over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Category:
Third Party
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Spent time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

I have a problem with the debugging version of art as installed in LArSoft, as follows:

ssh lbnegpvm02 # SLF5
source /grid/fermiapp/products/larsoft/setups
setup art v1_09_02 -q debug:e5:nu
gdb art

and running it with any options (e.g. --help) returns the following output:

GNU gdb (GDB) 7.7
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying" 
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from art...done.
(gdb) run --help
Starting program: 
/grid/fermiapp/products/larsoft/art/v1_09_02/slf5.x86_64.nu.e5.debug/bin/art 
Segmentation fault

I have tried on a SLF6 machine and my laptop (Gentoo Linux): same result.

But if I try the prof:e5:nu version, it works, and most relevant, if I setup gcc 4.8.1, the debugging does work
(and it follows that art v1_08_10 does work, as it uses gcc 4.8.1).

TotalView has no problem.

History

#1 Updated by Gianluca Petrillo over 6 years ago

I should mention that also on my Gentoo laptop gcc was the one compiled (locally) in the art bundle.
Yet the problem persists if I unsetup gcc and python, then set up sqlite, and then try the same gdb art.
In that case, I am using still gcc 4.8.2 (the system one, which happens to have the same version) and gdb 7.7.1 (as opposed to 7.7 shipped in UPS).

#2 Updated by Christopher Green over 6 years ago

  • Category set to Third Party
  • Status changed from New to Accepted
  • Start date deleted (05/16/2014)

We will continue to look into this problem. In the meantime, please use Totalview. Your system should now have 8.13.0; if it does not, please ask your product manager to obtain it from KITS.

#3 Updated by Christopher Backhouse over 6 years ago

I have the same problem since our move to the new art version (1.9.3). I can also use gdb in an optimized build, but that diminishes its usefulness.

I'm not familiar with totalview and would prefer to use gdb. Also, totalview isn't available off-site, for licensing reasons.

#4 Updated by Jim Kowalkowski over 6 years ago

Issue 14963 for GDB matches our problem. There is a patch available. Got the snapshot release of GDB from May that contains the patch and built it to see if it works with 4.8.x on our systems with art 1.09.02. It worked fine.
https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=210205 for the fix patch
https://sourceware.org/bugzilla/show_bug.cgi?id=14963 for the issue in the issue tracker
Used the source snapshot snapshot gdb-7.7.50.20140611 (gdb-7.7.50.20140611.tar.bz2).

We will probably not be able to integrate this into the system until after the first week of July (vacations).

#5 Updated by Christopher Green over 6 years ago

  • Status changed from Accepted to Resolved
  • Assignee set to Christopher Green
  • % Done changed from 0 to 100

We have been able to build a standalone UPS product for a snapshot of GDB built statically against GCC 4.8.2, but without depending upon it.

Please download the appropriate tarball from distro.fnal.gov/packages/gdb. You will be able to override the gdb we ship with the compiler with:

setup -B gdb v7_7_current_20140611

Please let us know immediately if you discover any further problems using GDB on Linux.

#6 Updated by Christopher Green about 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF