Project

General

Profile

Bug #6094

Fcl expansion doesn't handle absolute path includes.

Added by Herbert Greenlee over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
05/01/2014
Due date:
% Done:

0%

Estimated time:
Occurs In:
Scope:
Internal
Experiment:
-
SSI Package:
Duration:

Description

#includes in fcl files don't work if the included file is specified using an absolute path (starting with either "/" or "./").


Related issues

Is duplicate of art - Support #6087: Fcl expansion doesn't handle absolute path includes.Closed04/30/2014

History

#1 Updated by Rob Kutschke over 5 years ago

For what it's worth, Mu2e does not consider this a bug. We explicitly requested this feature. I believe (Chris/Marc can confirm) that It is possible to change this on a per experiment basis.

Do you know about the environment variable FHICL_FILE_PATH ? Mu2e felt that this provided enough flexibility for development and enough control to ensure that people did not sneak uncontrolled configurations into production jobs.

#2 Updated by Christopher Green over 5 years ago

  • Status changed from New to Rejected

See issue #6087.



Also available in: Atom PDF