Project

General

Profile

Bug #5956

HTCondorCE attributes write invalid XML on reconfig

Added by Burt Holzman about 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
High
Category:
Factory
Target version:
Start date:
04/17/2014
Due date:
% Done:

0%

Estimated time:
First Occurred:
Occurs In:
Stakeholders:

CMS, OSG

Duration:

Description

From Jeff:

Hello glideinWMS support,

Tony was helping me set up the HTCondorCE attributes in v3_2_4, and we
encountered and unexpected behavior, so I am reporting a bug.

I added the following lines to an entry:
<submit_attrs>
<submit_attr name="+jobtype" value="single"/>
<submit_attr name="+maxMemory" value="16000"/>
<submit_attr name="+xcount" value="8"/>
</submit_attrs>

On reconfig, they were unexpectedly modified to:
<+jobtype value="single"/>
<+maxMemory value="16000"/>
<+xcount value="8"/>

This is malformed xml, so it breaks on further reconfigs:

./factory_startup reconfig
Using default factory config file:
/home/gfactory/glideinsubmit/glidein_v3_1.cfg/glideinWMS.xml
Reconfiguring the factoryTraceback (most recent call last):
File "/home/gfactory/glideinwms/creation/reconfig_glidein", line 224,
in ?
params=cgWParams.GlideinParams(usage, WEB_BASE_DIR, args)
File
"/home/gfactory/glideinwms/creation/../../glideinwms/creation/lib/cWParams.py",
line 179, in init
self.load_file(self.cfg_name)
File
"/home/gfactory/glideinwms/creation/../../glideinwms/creation/lib/cWParams.py",
line 227, in load_file
self.data=xmlParse.xmlfile2dict(fname,use_ord_dict=True)
File
"/home/gfactory/glideinwms/factory/../../glideinwms/lib/xmlParse.py",
line 86, in xmlfile2dict
raise CorruptXML("XML corrupt in file %s: %s" % (fname, e))
glideinwms.lib.xmlParse.CorruptXML: XML corrupt in file /tmp/tmpjcgE8J:
not well-formed (invalid token): line 940, column 19
[FAILED]

History

#1 Updated by Anthony Tiradani about 6 years ago

  • Status changed from Assigned to Feedback
  • Assignee changed from Anthony Tiradani to Marco Mambelli

The root cause was the need for special formatting rules. Please review branch v3_2/5956.

#2 Updated by Marco Mambelli about 6 years ago

  • Status changed from Feedback to Assigned
  • Assignee changed from Marco Mambelli to Anthony Tiradani

Reviewed. Nothing to discuss/change.
Ready for merging.

#3 Updated by Parag Mhashilkar about 6 years ago

  • Status changed from Assigned to Resolved

Merged it to branch_v3_2. Resolving the ticket.

#4 Updated by Parag Mhashilkar about 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF