Project

General

Profile

Support #5943

Investigate gcc 4.8.1 optimizer issue in NetMonOutput_module

Added by Kurt Biery about 5 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Known Issues
Target version:
Start date:
04/17/2014
Due date:
% Done:

0%

Estimated time:
32.00 h
Experiment:
Co-Assignees:
Duration:

Description

When we upgraded from gcc 4.7.1 to 4.8.1, there was a problem in the send_init_message() method in NetMonOutput_module. To work around this problem, we disabled optimization of that method using compiler "pragma" directives.

We should investigate what the source of the problem is and communicate with folks in the SSI group to describe it and learn possible fixes. This may entail creating a small stand-alone piece of code that demonstrates the problem.

From my notes from last August, it seems that the problem was the optimizer would somehow affect the serialization of the ParameterSet strings in such a way that they wouldn't appear in the message that was sent.

The symptom seems to have been Aggregator errors like the following:

Fri Aug 23 16:06:43 0500 2013: %MSG-s ArtException: Aggregator-6650 JobSetup
Fri Aug 23 16:06:43 -0500 2013: cet::exception caught in art
Fri Aug 23 16:06:43 -0500 2013: ---
FatalRootError BEGIN
Fri Aug 23 16:06:43 0500 2013: Fatal Root Error: @SUB=TBufferFile::ReadObject
Fri Aug 23 16:06:43 -0500 2013: Got object of wrong class (Got string while expecting map<art::BranchKey,art::BranchDescription>)
Fri Aug 23 16:06:43 -0500 2013: ---
FatalRootError END
Fri Aug 23 16:06:43 -0500 2013: %MSG

History

#1 Updated by Eric Flumerfelt over 2 years ago

  • Category set to Known Issues
  • Target version deleted (575)

NetMonOutput_module is now RootMPIOutput_module. We should check if the rest of the issue still applies.

#2 Updated by Eric Flumerfelt over 1 year ago

  • Status changed from New to Closed
  • Target version set to artdaq v3_00_01

This issue is no longer applicable. It was related to misunderstandings on the "art goo" that was needed in the init message.



Also available in: Atom PDF