Project

General

Profile

Support #5932

Do Standard 4 tests for v3.2.5 rpm when released

Added by Parag Mhashilkar about 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Parag Mhashilkar
Category:
test category
Target version:
Start date:
04/16/2014
Due date:
% Done:

0%

Estimated time:
Stakeholders:
Duration:

Description

Usual tests, upgrade and new install on sl5 & sl6


Related issues

Related to GlideinWMS - Bug #6421: new RPM installation failing Closed06/06/2014

Related to GlideinWMS - Bug #6484: Factory rpm install privsep failure Closed06/17/2014

History

#1 Updated by Parag Mhashilkar about 6 years ago

3.2.5 rpms should be in the dev repo shortly. John please do the OSG standard 4 tests as usual.

#2 Updated by John Weigand almost 6 years ago

SL5 Upgrade of factory and frontend (and unless otherwise noted, will be same for SL6)
  1. After yum update on both the factory and frontend, both xml files were touched yet not updated. Assume the not updated was expected but why were they touched.
  2. On the factory, after a 'service gwms-factory upgrade', the glideinWMS.xml was changed.
    [root@fermicloud033 gwms-factory] diff -bBw glideinWMS.xml glideinWMS.xml~
    43,44c43  NOT SURE WHY THIS HAD TO BE CHANGED
    <                <submit_attrs>
    <                </submit_attrs>
    ---
    >                <submit_attrs/>
    
  3. On the frontend, after a 'service gwms-frontend upgrade', the frontend.xml was changed.
    [root@fermicloud172 gwms-frontend] diff -bBw  frontend.xml frontend.xml~
    1,7c1 ADDED SEVERAL NEW ATTRIBUTES AND A CONFIG ELEMENT
    < <frontend advertise_delay="5" 
          advertise_with_multiple="True" 
          advertise_with_tcp="True" 
          frontend_monitor_index_page="False" 
          frontend_name="fermicloud172-fnal-gov_OSG_gWMSFrontend" 
          frontend_versioning="False" 
          group_parallel_workers="2" 
          loop_delay="60" 
          restart_attempts="3" 
          restart_interval="1800">
    <    <config>
    <       <idle_vms_total curb="200" max="1000"/>
    <       <idle_vms_total_global curb="200" max="1000"/>
    <       <running_glideins_total curb="90000" max="100000"/>
    <       <running_glideins_total_global curb="90000" max="100000"/>
    <    </config>
    ---
    > <frontend advertise_delay="5" 
          frontend_name="fermicloud172-fnal-gov_OSG_gWMSFrontend" 
          loop_delay="60" 
          advertise_with_multiple="True" 
          advertise_with_tcp="True" 
          frontend_monitor_index_page="False" 
          frontend_versioning="False">
    -----------------------------------
    10,11c4,5 ADDED BACKUP_COUNT ATTRIBUTE
    <          <process_log backup_count="5" extension="info" max_days="7.0" max_mbytes="100.0" min_days="3.0" msg_types="INFO"/>
    <          <process_log backup_count="5" extension="err" max_days="7.0" max_mbytes="100.0" min_days="3.0" msg_types="DEBUG,ERR,WARN,EXCEPTION"/>
    ---
    >          <process_log extension="info" max_days="7.0" max_mbytes="100.0" min_days="3.0" msg_types="INFO"/>
    >          <process_log extension="err" max_days="7.0" max_mbytes="100.0" min_days="3.0" msg_types="DEBUG,ERR,WARN,EXCEPTION"/>
    ----------------------------------
    14c8 RESET MY PURPOSELY REMOVED START_EXPR
    <    <match match_expr="True" start_expr="True">
    ---
    >    <match match_expr="True">
    ----------------------------------
    32  ADDED THIS MONITOR_FOOTER ELEMENT
    <    <monitor_footer display_txt="" href_link=""/>
    ----------------------------------
    51d62 ADDED THIS ELEMENT TO THE groups --> group --> config ELEMENT
    <             <idle_vms_total curb="200" max="1000"/>
    ----------------------------------
    53d63  ADDED THIS ELEMENT TO THE groups --> group --> config ELEMENT
    <             <running_glideins_total curb="90000" max="100000"/>
    ----------------------------------
    55c65 RESET MY PURPOSELY REMOVED START_EXPR in the groups --> group --> match ELEMENT
    <          <match match_expr="True" start_expr="True">
    ---
    >          <match match_expr="True">
    ----------------------------------
    80,81c90,91  REMOVED THE group ATTRIBUTE 
    <       <collector DN="/DC=com/DC=DigiCert-Grid/O=Open Science Grid/OU=Services/CN=fermicloud172.fnal.gov" 
               group="default" 
               node="fermicloud172.fnal.gov:9618" secondary="False"/>
    <       <collector DN="/DC=com/DC=DigiCert-Grid/O=Open Science Grid/OU=Services/CN=fermicloud172.fnal.gov" 
               group="default" 
               node="fermicloud172.fnal.gov:9620-9660" secondary="True"/>
    ---
    >       <collector DN="/DC=com/DC=DigiCert-Grid/O=Open Science Grid/OU=Services/CN=fermicloud172.fnal.gov" 
               node="fermicloud172.fnal.gov:9618" secondary="False"/>
    >       <collector DN="/DC=com/DC=DigiCert-Grid/O=Open Science Grid/OU=Services/CN=fermicloud172.fnal.gov" 
               node="fermicloud172.fnal.gov:9620-9660" secondary="True"/>
    

Testing proceeding.

#3 Updated by John Weigand almost 6 years ago

Correction to the last entry regarding the collector element.
It added the group attribute. It did not remove it.

#4 Updated by John Weigand almost 6 years ago

Also of note, when I removed the <match start_expr attribute and did a reconfig, the start_expr attribute stayed removed.

#5 Updated by John Weigand almost 6 years ago

SL5/SL6 Fresh factory install
From osg-development v3.2.5

[root@fermicloud101 init.d] gwms-factory upgrade
awk: cmd. line:1: fatal: cannot open file `/var/lib/gwms-factory/work-dir/glidein.descript' for reading (No such file or directory)
awk: cmd. line:1: fatal: cannot open file `/var/lib/gwms-factory/work-dir/glidein.descript' for reading (No such file or directory)
Using default factory config file: /etc/gwms-factory/glideinWMS.xml
usage: reconfig_glidein { -force_name name -writeback yes|no -update_scripts yes|no -xml xml -update_def_cfg yes|no [-force_delete] [-xslt_plugin_dir xdir] | -help }

This is not a '' config file ('gfactory_instance' found)
Upgrading the factory                                      [FAILED]

This is caused by these lines in the /etc/init.d/gwms-factory script.

factory_name=`awk '/^FactoryName /{print $2}' ${factory_dir}/glidein.descript`
glidein_name=`awk '/^GlideinName /{print $2}' ${factory_dir}/glidein.descript`

The glidein.descript file does not exist on an initial install.

I would also question as to why we would be going after these names in this file as they are attributes in the /etc/gwms-factory/glideinWMS.xml file. If one was to change the glideinWMS.xml file for these attributes, will they be over-ridden on a reconfig/update.

#6 Updated by John Weigand almost 6 years ago

Factory install (sl5/6)
Execution of the initial service gwms-factory upgrade fails
with a privilege separation error. See ticket #6484 for details.

#7 Updated by John Weigand almost 6 years ago

Did a preliminary test of the changes in branch v3/6421 for #6421.
Changes were successful.
John Weigand

#8 Updated by John Weigand almost 6 years ago

Fresh install test sl5/sl6
Completed testing of v3.2.5-1 with workarounds for the items already noted.
John Weigand

#9 Updated by John Weigand almost 6 years ago

Bug #6421 has been resolved in glideinwms-factory-3.2.5.1-1.osg32.el6.noarch
tested today 6/24/14
John Weigand

#10 Updated by John Weigand almost 6 years ago

  • Assignee changed from John Weigand to Parag Mhashilkar

#11 Updated by Parag Mhashilkar almost 6 years ago

  • Status changed from New to Closed

Closing the ticket since we are releasing v3_2_5_1 to address the issues found here



Also available in: Atom PDF