Project

General

Profile

Bug #5789

@mrb setEnv@ does not set up libraries correctly (@larsoft@ @v1_00_06@)

Added by Gianluca Petrillo almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/31/2014
Due date:
% Done:

100%

Estimated time:
Duration:

Description

Following the LArSoft setup instructions:

chdir test
source /grid/fermiapp/lbne/software/setup_lbne.sh
mrb newDev -v v1_00_06 -q e4:prof
source /lbne/app/users/petrillo/LArSoft/test/localProducts_larsoft_v1_00_06_e4_prof/setup
cd "$MRB_SOURCE" 
mrb g larsoft_suite
cd "$MRB_BUILD" 
source mrb setEnv

fails to correctly set up the library paths (maybe a silent error occurs before it has the time to do so).
For example:
$ tr ':' '\n' <<< "$LD_LIBRARY_PATH" 
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larsoft/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/lareventdisplay/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larexamples/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larana/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larreco/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larsim/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larevt/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/lardata/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larpandora/lib
/lbne/app/users/petrillo/LArSoft/test/build_slf5.x86_64/larcore/lib
/afs/fnal.gov/files/home/room1/petrillo/local/lib
/afs/fnal.gov/files/home/room1/petrillo/local/opt/cbtf_u13/lib64
/afs/fnal.gov/files/home/room1/petrillo/local/opt/krellroot_u13/lib64
/afs/fnal.gov/files/home/room1/petrillo/local/opt/openss_u13/lib64
/afs/fnal.gov/files/home/room1/petrillo/local/opt/fast/proftools/lib
/afs/fnal.gov/files/home/room1/petrillo/local/opt/fast/SimpleProfiler/Linux.x86_64

(the last entries are local library I need, existing before MRB is set up)
Quick test:
$ python
python: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

This might be specific to larsoft v1_00_06 as, interestingly enough, it does not happen when only lbnecode (v1_00_05) is in.
MRB is set up as v0_07_04.

History

#1 Updated by Lynn Garren almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Lynn Garren

Interesting. I can reproduce this on uboonegpvm01. But I can build quite happily elsewhere. Curious....

#2 Updated by Lynn Garren almost 7 years ago

Putting mrb v0_06_01 back in place for now. I do NOT see the problem when using mrb v0_06_01. You will, however, need to start with a fresh login and a new build directory.

Lynn

#3 Updated by Gianluca Petrillo almost 7 years ago

Thank you, Lynn.
I have seen the problem in lbnegpvm01.fnal.gov.
I first encountered the problem when moving from an older working area with MRB 0.6.1.
I confirm that my v0_06_01 area was not affected, and updating to 0.7.3/4 showed the problem (but then, updating the area is questionable).

From my tests I think I collected that:
- adding only lbnecode does not show a problem
- if I set up larsoft (v1_00_06) before source mrb setEnv, the first set up is complete but then setEnv corrupts it (probably, it "unsetups" it first)
- the problem is still there with larsoft v1_00_05
- made sure that PRODUCTS is empty before starting... it did not help

Back to 0.6.1, everything is sweet.

#4 Updated by Lynn Garren almost 7 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed in mrb v0_08_01.

#5 Updated by Lynn Garren over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF