Project

General

Profile

Feature #5778

Increase supported graphic file types

Added by Cheng-Yang Tan over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
03/28/2014
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Some scopes just spit out bmp or tif. Please add BMP and TIF as an accepted types.

History

#1 Updated by Kyle Hazelwood over 5 years ago

  • Status changed from New to Rejected
  • Priority changed from Normal to Low

Unfortunately BMP is uncompressed and therefore very large in filesize for an image. I chose not to include BMP because it takes a large amount of time to save to the db, takes up an unecessarily large amount of space on the db, and is very memory intensize to produce a thumbnail of.

TIFF/TIF has been excluded because of how extensible it is. I can not guarantee that the elog can serve up the image after it has been uploaded. From wikipedia: "The tagged structure was designed to be easily extendible, and many vendors have introduced proprietary special-purpose tags – with the result that no one reader handles every flavor of TIFF file".



Also available in: Atom PDF