Project

General

Profile

Feature #5690

FCL file parameters not properly tracked

Added by Wesley Ketchum over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Application
Target version:
Start date:
03/18/2014
Due date:
% Done:

100%

Estimated time:
Scope:
Internal
Experiment:
-
SSI Package:
art
Duration:

Description

We've come across a case where the input fcl file parameters are not properly tracked.

The file used to run the job is attached as original_fcl.fcl. There are a number of includes, but the key part is the services.user.TriggerAlgoMicroBoone parameter, which is set up and then has some default parameters overwritten.

We can run with $ART_DEBUG_CONFIG=1, and get the debug_config.fcl file attached. TriggerAlgoMicroBoone is in that file.

But, after running the job, running "config_dumper" on the output file produces the config_dump.fcl file, which has no TriggerAlgoMicroBoone in it. We do know that this parameter is being read in and used, as we spent some time debugging an issue where we uncovered a difference in the parameter values used which caused the job to run differently.

original_fcl.fcl (4.68 KB) original_fcl.fcl Wesley Ketchum, 03/18/2014 04:01 PM
config_dump.fcl (30 KB) config_dump.fcl Wesley Ketchum, 03/18/2014 04:01 PM
debug_config.fcl (42.7 KB) debug_config.fcl Wesley Ketchum, 03/18/2014 04:01 PM

Related issues

Is duplicate of art - Feature #3639: Recovering Parameter Sets used to Configure ServicesClosed2013-05-01

History

#1 Updated by Christopher Green over 5 years ago

  • Tracker changed from Bug to Feature
  • Category set to Application
  • Status changed from New to Resolved
  • Target version set to 1.09.03
  • % Done changed from 0 to 100
  • SSI Package art added
  • SSI Package deleted ()

The original (admittedly not comprehensive) feature set of config_dumper only prints out module configurations. In the upcoming release, this functionality has been extended to print out entire parameter sets, module configurations or service configurations. Please see the original issue #3639 for details.

#2 Updated by Marc Paterno about 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF