Project

General

Profile

Bug #5650

sourcing setup or setups fails on tcsh if not the login shell

Added by Christopher Green over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
03/13/2014
Due date:
% Done:

0%

Estimated time:
Experiment:
Duration:

History

#1 Updated by Christopher Green over 5 years ago

[greenc@mac-120590] ~ $ tcsh
[mac-120590:~] greenc% source ~/work/cet-is/external-products/setups
a = 3
b = 4
a = 3
b = 4
a = 3
b = 4
setups: failed to find myself
a = 3
b = 4
a = 3
b = 4
a = 3
b = 4
Bad : modifier in $ (-).
[mac-120590:~] greenc% source ~/work/cet-is/external-products/setup
a = 3
b = 4
a = 3
b = 4
a = 3
b = 4
Illegal variable name.
[mac-120590:~] greenc% ls -l ~/work/cet-is/external-products/ups
total 0
drwxr-xr-x  3 greenc  staff  102 Feb  7 11:16 current.chain
drwxr-xr-x  6 greenc  staff  204 Feb  7 11:16 v5_0_4
drwxr-xr-x  3 greenc  staff  102 Feb  7 11:16 v5_0_4.version

Note, UPS was not already set up in the login shell here.

#2 Updated by Lynn Garren over 5 years ago

  • Status changed from New to Feedback
  • Target version set to v5_0_5

This appears to be fixed in ups v5_0_5. Please verify.

#3 Updated by Christopher Green over 5 years ago

Seems to be. However, Paul has found more problems. Issue entries incoming.

#4 Updated by Lynn Garren over 5 years ago

  • Status changed from Feedback to Resolved

OK - resolving this one.

#5 Updated by Marc Mengel over 2 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF