Project

General

Profile

Bug #5515

Error setting up local products on uboonegpvm04 (was: Broken release?)

Added by Jonathan Asaadi over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
02/25/2014
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Hello folks,

So I am trying to go back to a nightly release I created last week and continue developing and I get an error. I only get this error on uboonegpvm04....this works on other uboone machines Here is the exact set of commands I run

source /grid/fermiapp/uboone/software/setup_uboone.sh
setup uboonecode nightly -q debug:e4
setup ubtools
setup jobsub_tools
cd /uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/
source localProducts_larsoft_nightly_debug_e4/setup
cd build/
source mrb s
source mrb slp

Here is the error I get:

MRB_SOURCE=/uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/srcs
MRB_BUILDDIR=/uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/build
MRB_PROJECT=larsoft
MRB_PROJECT_VERSION=nightly
MRB_QUALS=debug:e4
MRB_INSTALL=/uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/localProducts_larsoft_nightly_debug_e4

PRODUCTS=/uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/localProducts_larsoft_nightly_debug_e4:/grid/fermiapp/uboone/software/products:/grid/fermiapp/products/uboone:/grid/fermiapp/products/larsoft:/grid/fermiapp/products/common/db

The working build directory is /uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/build
The source code directory is /uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/srcs
----------- check this block for errors -----------------------
----------------------------------------------------------------
local product directory is /uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/localProducts_larsoft_nightly_debug_e4
----------- check this block for errors -----------------------
/uboone/app/users/jasaadi/NewRelease_git_mrb_debug_v2/localProducts_larsoft_nightly_debug_e4/larreco/v1_00_02/slf6.x86_64.e4.debug directory not found: SETUP ABORTED
----------------------------------------------------------------

I am working on uboonegpvm04.

When I switch to uboonegpvm05, the setup works fine.

Thought I should let someone know...

History

#1 Updated by Gianluca Petrillo over 5 years ago

  • Subject changed from Broken release? to Error setting up local products on uboonegpvm04 (was: Broken release?)
  • Status changed from New to Feedback
  • Target version changed from develop/HEAD to nightly

I would suggest you to skip the source mrb setupLocalProducts (slp) the first time.
There are some local products in your local area, but none of them is yet compiled for Scientific Linux 6 (slf6), which is the type of machine uboonegpvm04 (and only that one) is.
Skip that and compile everything (mrb install) and the next time all the products in your local area will have also a SLF6 version and everything will be fine.
If you just want easier life, do not mix working areas of SLF5 and SLF6 (i.e. new working area for uboonegpvm04).

By the way, the release is not broken (at least, not for this reason).

#2 Updated by Lynn Garren over 5 years ago

  • Status changed from Feedback to Resolved

In general, there is no reason to source mrb slp before building. This is used to setup local products after you have built and installed them.

#3 Updated by Lynn Garren over 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF