Project

General

Profile

Bug #5441

Un-refining by subject doesn't seem to work

Added by Phil Adamson over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/14/2014
Due date:
% Done:

0%

Estimated time:
Duration:

Description

Refining by subject works, but un-refining by subject doesn't.

Specifically:
Refine by Recycler
Refine by RR 12 batch slip-stacking study.
(so far, so good.)
Refine by Operations
(realize that I don't see new entries, because I have a subject selected)
Un-refine by RR 12 batch slip stacking
(new entries fail to appear)

Subsequently de-selecting a re-selecting Operations log makes that log visible.


Related issues

Is duplicate of Elog - Bug #5026: Subject selected but not refiningClosed12/02/2013

History

#1 Updated by Kyle Hazelwood over 5 years ago

  • Status changed from New to Assigned

I've seen this and I think I have a fix in the test server now but I want to test it some more before releasing (The fix required changing the main DB query for retrieving entries). The way to get around the bug for now is to refine/unrefine by any non subject to reset the last modified date calculation.

#2 Updated by Kyle Hazelwood over 5 years ago

  • Status changed from Assigned to Feedback

I removed the date check caching scheme in the latest release. The caching was not saving a noticable amount of time and was not working correctly. If page load time becomes a problem I'll have to revert. I'm working on a different caching scheme.

#3 Updated by Kyle Hazelwood over 5 years ago

  • Status changed from Feedback to Closed

I removed the date check caching scheme in the latest release. The caching was not saving a noticable amount of time and was not working correctly. If page load time becomes a problem I'll have to revert. I'm working on a different caching scheme.



Also available in: Atom PDF