Project

General

Profile

Bug #5363

LArPandora/larpandoraservices.fcl should be renamed as it does not figure any services, but a module instead.

Added by Brian Rebel over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
02/06/2014
Due date:
% Done:

100%

Estimated time:
Occurs In:
Experiment:
-
Co-Assignees:
Duration:

Description

The name of that configuration file is confusing as it implies it is configuring a service, but in fact is configuring a module.

History

#1 Updated by Erica Snider over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Gianluca Petrillo

#2 Updated by Gianluca Petrillo over 6 years ago

  • Target version set to x_future_release

The file has been renamed into larpandora/LArPandoraInterface/pandoramodules.fcl.
The change potentially breaks existing FCL files (for example, it is known to break sone in ubfcl package).
All the FCL files affected which reside in the "LArSoft suite", uboonecode and lbnecode have been fixed already (they sum up to... one).

Since this is a breaking change and the issue is far from being critical, the fix is put on hold in the branch: features/Issue5363 .

Still considering to implement the suggestion of Herbert Greenlee, of adding a copy of pandoramodules.fcl already in the current version.

#3 Updated by Gianluca Petrillo over 6 years ago

  • Status changed from Assigned to Feedback

#4 Updated by Gianluca Petrillo over 6 years ago

As suggested by Herbert, in v1_00_04 there are both the "final" pandoramodules.fcl and one legacy pandoraservices.fcl with a big warning in it suggesting to migrate.
It will stay there until the experiments tell us they can afford its removal.

#5 Updated by Gianluca Petrillo over 6 years ago

  • Status changed from Feedback to Accepted
  • Target version changed from x_future_release to v1_01_00

#6 Updated by Gianluca Petrillo over 6 years ago

  • % Done changed from 0 to 100

LArPandora/larpandoraservices.fcl has been finally removed by Andrew Blake.

#7 Updated by Lynn Garren over 6 years ago

  • Status changed from Accepted to Resolved

#8 Updated by Gianluca Petrillo over 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF