Project

General

Profile

Bug #5290

UPS setup to avoid duplicative unsetup / setup of already setup products under -B

Added by Christopher Green almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
01/30/2014
Due date:
% Done:

0%

Estimated time:
Experiment:
-
Co-Assignees:
Duration:

Description

When -B is used at the command line, nested dependencies (if already setup) are verified for version / qualifier. However, if the correct version is already setup, it is unsetup and re-setup, which is unnecessary because the safety is already provided by -B.
If -B is in operation, nested dependencies that are already setup should not be re-setup. I believe this will at a stroke solve LArSoft's setup time problems. Safety is further increased if feature requests #4887 and #4889 are implemented.

History

#1 Updated by Marc Mengel almost 7 years ago

  • Tracker changed from Feature to Bug

Changing this to a Bug -- this is supposed to be the behaviour already.

#2 Updated by Marc Mengel almost 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Marc Mengel
  • Target version set to v5_0_5

#3 Updated by Marc Mengel almost 7 years ago

Chris,

A specific test case would be appreciated...

#4 Updated by Lynn Garren almost 7 years ago

That's easy: login to some gpvm machine
source /grid/fermiapp/products/larsoft/setup(s)
setup larsoft v1_00_01 -q e4:prof
Takes at least 30 seconds.

#5 Updated by Christopher Green almost 7 years ago

I'm certainly unable to reproduce the 30s figure. On two different mu2egpvmXX (very low load), I get 7s, -B notwithstanding. For novagpvm01 (load 1.5) I get 9s. I can only imagine the 30s was bluearc related.

It does appear from the makeup of the TMP file that there is no duplication of the kind I had believed was occurring. My apologies for misunderstanding what was happening.

#6 Updated by Marc Mengel almost 7 years ago

  • Status changed from Assigned to Rejected

"Rejecting" this bug report, as we are unable to reproduce it.

#7 Updated by Marc Mengel almost 7 years ago

  • Status changed from Rejected to Closed

Also available in: Atom PDF