Project

General

Profile

Bug #5246

Remid+cosrej failings w/ Data calibration constants in NuMI Data

Added by Gavin Davies almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
01/23/2014
Due date:
% Done:

100%

Estimated time:
Duration:

Description

After reconstruction, the pid job fails when applying data calibration constants to NuMI data.
The following errors (and subsequent seg fault) occur seemingly linked:

RunHistory: Loading FEB and APD installation information
+++ processing event:run: 12250 subRun: 20 event: 68372 time:5963687297534761976
++++
+ processing path for event:reco
++++++ module for event:remid
Got new connection
DBWeb query: http://dbdata0.fnal.gov:8085/NOvAConDev/app/get?table=fardet.calib_atten_consts&bits=2&t0=1&t1=100&columns=coeff_exp,atten_length,background,edge_low,edge_high,coeff_low,coeff_high,chisq
Got 46810 rows from database
Got new connection
DBWeb query: http://dbdata0.fnal.gov:8085/NOvAConDev/app/get?table=fardet.calib_atten_points&bits=2&t0=1&t1=100&columns=w,factor
Got zero rows from database. Is that expected?
Closed connection
Closed connection
Got new connection
DBWeb query: http://dbdata0.fnal.gov:8085/NOvAConDev/app/get?table=fardet.calib_abs_consts&bits=2&t0=1&t1=100&columns=meu,meu_err,meu_gev
Got 2 rows from database
Closed connection
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
--- <ERROR> Reader : 1-th variable of the event is NaN --> return MVA value 999,
--
<ERROR> Reader : that's all I can do, please fix or remove this event.
++++++ finished for event:remid
++++++ module for event:cosrej
RunHistory: Loading FEB and APD installation information
RunHistory: loading pixel enable masks
RunHistory: loading pixel thresholds
done!
Segmentation fault

It is reproducible interactively:
setup_nova -r S14-01-20

nova -c /nova/app/users/gsdavies/test140120/job/pidproductionDatacalibjob.fcl /scratch/nova/gsdavies/gridwoes/fardet_r00012250_s20_numi_S14-01-20_v1.data.reco.root

If I remove cosrej and numue from the job fcl the job runs successfully.
I've seen instances of a subsequent cosrej job running ok after this on the pid output file, though not in this case.
gdb sheds no light on this issue.

This job is successful on the same pid fcl file as above as a reference:
nova -c /nova/app/users/gsdavies/test140120/job/pidproductionDatacalibjob.fcl fardet_r00012040_s20_numi_S14-01-20_v1.data.reco.root

History

#1 Updated by Nicholas Raddatz almost 6 years ago

  • % Done changed from 0 to 100

This issue came up when none of the hits on a track where able to be made into recohits. This led to a division by zero in ReMId and hence the Reader Error. Fixed by revision 7950. Not quite sure why this caused a segfault later down the processing line, presumably because cosrej is not finding pid value higher than its bestval of -999 causing it to use the index -1 in the remid vector (lines 171-224 of cosrej).

#2 Updated by Nicholas Raddatz almost 6 years ago

  • Status changed from New to Resolved

#3 Updated by Gavin Davies over 5 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF