Project

General

Profile

Bug #5225

Test run error

Added by Seongtae Park almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/18/2014
Due date:
% Done:

0%

Estimated time:
Occurs In:
Experiment:
LBNE
Co-Assignees:
Duration:

Description

Hello,

I tried to run a module 'RawEVD35t_module.cc' using 'rawevd35t.fcl'.
I put those files in '/lbne/app/users/seongtae/larsoft_mydev/srcs/lbnecode/lbne/Simulation/ just for the test of build and run.
I did'n see any error during building.
But i got this error when i try to run it.

-------------------------------------------------------------------------------------------
<lbnegpvm01.fnal.gov> lar c rawevd35t.fcl
Failed to parse the configuration file 'rawevd35t.fcl' with exception
---
search_path BEGIN
Can't find file "job/services_lbne.fcl"
---- search_path END

Art has completed and will exit with status 7002.
-------------------------------------------------------------------------------------------

The followin is the list of commands i executed for this test.
I already setup the working environment before and this is fresh login.

ssh -Y
cd /lbne/app/users/seongtae
source /grid/fermiapp/products/larsoft/setup
setup git
setup gitflow
setup mrb
export MRB_PROJECT=larsoft
cd larsoft_mydev
source /lbne/app/users/seongtae/larsoft_mydev/localProducts_larsoft_v0_02_01_debug_e4/setup
setup larsoft v0_02_01 -q debug:e4
cd build //I already copied the source files in the 'Simulation' pakage.
source mrb s
mrb i -j4
setup lbnecode v0_01_00 -q debug:e4

//so far no error.

But...
<lbnegpvm01.fnal.gov> lar c rawevd35t.fcl
Failed to parse the configuration file 'rawevd35t.fcl' with exception
---
search_path BEGIN
Can't find file "job/services_lbne.fcl"
---- search_path END

Art has completed and will exit with status 7002.

What am i missing or doing something wrong?
Please give some help on this issue.

Thaks!

Seongtae Park

History

#1 Updated by Erica Snider almost 6 years ago

  • Status changed from New to Resolved
  • Assignee set to Erica Snider

Hi,
The problem is that you have the following line in rawevd35t.fcl:

#include "job/services_lbne.fcl"

The "job" in the include path is no longer needed. Just drop that, and art will find it.

Erica

#2 Updated by Erica Snider almost 6 years ago

  • Status changed from Resolved to Closed


Also available in: Atom PDF