Project

General

Profile

Feature #5218

Add support for the WLCG Machine/Job features environment

Added by Igor Sfiligoi over 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Glidein
Target version:
Start date:
01/17/2014
Due date:
% Done:

0%

Estimated time:
Stakeholders:

CMS

Duration:

Description

A WLCG task force has defined a specification for propagating machine information to the jobs:
https://twiki.cern.ch/twiki/bin/view/LCG/WMTEGEnvironmentVariables
https://twiki.cern.ch/twiki/bin/view/LCG/MachineJobFeatures

The glideins should make use of them, if available.

Also, may be useful for the glideins to create a per-user-job environment that follows the spec.


Related issues

Is duplicate of GlideinWMS - Feature #13281: Incorporate the information based on the machine & job features project into glidein classadsClosed07/19/2016

History

#1 Updated by Parag Mhashilkar over 6 years ago

  • Target version set to v3_x

#2 Updated by Igor Sfiligoi over 6 years ago

They have published a standard client python library for the pilots to use.
They are pushing for it to be deployed by the sites.
http://linuxsoft.cern.ch/wlcg/sl6/SRPMS/python-mjf-0.0.2-2.el6.src.rpm
https://github.com/roiser/JobMachineFeatures

We should decide if we want to rely on the site-provided library, or use our own copy.

#3 Updated by Parag Mhashilkar about 5 years ago

  • Assignee deleted (Igor Sfiligoi)

Igor Sfiligoi's tickets. These were some ideas brewing up in his mind but they never materialized or got priority.

#4 Updated by Parag Mhashilkar over 3 years ago

  • Is duplicate of Feature #13281: Incorporate the information based on the machine & job features project into glidein classads added

#5 Updated by Parag Mhashilkar over 3 years ago

  • Status changed from New to Closed
  • Assignee set to Marco Mascheroni
  • Target version changed from v3_x to v3_2_16
  • Stakeholders updated (diff)


Also available in: Atom PDF